WordPress.org

Make WordPress Core

Opened 12 years ago

Closed 11 years ago

#10470 closed enhancement (wontfix)

more pages for posts - displayed by category

Reported by: mch Owned by: ryan
Milestone: Priority: normal
Severity: normal Version:
Component: Query Keywords: 2nd-opinion has-patch
Focuses: Cc:

Description

Extension of current option page_for_posts to allows store list of page_id -> caregory_id array.The query is modified to filter only proper category posts when displaying page_for_posts.

Attachments (1)

page_for_posts.patch (10.6 KB) - added by mch 12 years ago.

Download all attachments as: .zip

Change History (11)

#1 @Denis-de-Bernardy
12 years ago

  • Component changed from General to Query
  • Keywords 2nd-opinion added
  • Milestone changed from Unassigned to Future Release
  • Owner set to ryan

#2 @mch
12 years ago

I already have that code. Shall i attach patch file for 2.8.2 ?

#3 @Denis-de-Bernardy
12 years ago

for trunk, rather.

@mch
12 years ago

#4 @mch
12 years ago

added the patch for trunk at rev 11742

#5 @mch
12 years ago

is there gonna be any progress ?

#6 @hakre
12 years ago

  • Keywords has-patch added
  • Milestone changed from Future Release to 3.0

Seems valid to me, changed Milestone to 3.0 which is there for improvements.

#7 @mch
12 years ago

thank you :)

#8 follow-up: @scribu
12 years ago

  • Milestone 3.0 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Same idea as #11550

#9 in reply to: ↑ 8 @mch
11 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Replying to scribu:

Same idea as #11550

Not same idea, my functionality actually extends current behaviour, the #11550 is just modification of the functionality.

My patch allows to specify MORE pages and the category content being there displayed. The #11550 does only URL rewriting for posts in specific category.

#10 @nacin
11 years ago

  • Resolution set to wontfix
  • Status changed from reopened to closed

Zero traction. Closing as wontfix. Alternatively, a duplicate of #11550.

Note: See TracTickets for help on using tickets.