WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 10 months ago

Last modified 10 months ago

#12014 closed defect (bug) (duplicate)

Author selection becomes performance issue with large userbase with quick edit in admin

Reported by: wpmuguru Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Quick/Bulk Edit Keywords:
Focuses: Cc:

Description

MU Trac Ticket: http://trac.mu.wordpress.org/ticket/1086

When the author user base becomes too large, the script handling for the quick edit or inline edit begins to fail. In our specific situation, we have over 14000 authors for a single blog. This is causing the inline-edit-post.js to timeout and not completely render all the fields.

Since this would be such a rare issue, I think the best solution would be to just offer a hook that could keep the author option from being a part of the quick edit form. Since the field value is filled by js, then just replacing it with a hidden input keeps the author from being replaced on update.

Change History (5)

comment:1 @Denis-de-Bernardy6 years ago

probably dup of #5407

comment:2 @voyagerfan57616 years ago

  • Cc WordPress@… added

comment:3 @nacin5 years ago

  • Milestone changed from Unassigned to Future Release

comment:4 @chriscct710 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

This scalability issue is caused by wp_dropdown_users here. Marking as duplicate of #19867.

comment:5 @DrewAPicture10 months ago

  • Milestone Future Release deleted
Note: See TracTickets for help on using tickets.