WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 9 months ago

Last modified 9 months ago

#14042 closed defect (bug) (duplicate)

Detach / Unattach

Reported by: jimisaacs Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: Media Keywords:
Focuses: Cc:

Description

I am just creating a ticket based on this idea:
http://wordpress.org/extend/ideas/topic/unattaching

I did a search in here and couldn't find one, so I thought I'd go ahead.

Please read through that thread for more information on the idea, and solution.

As I said in that thread, a friend of mine already has a patch for this, I just need to see if he can get it up here, he's a busy man ;)

Change History (16)

comment:1 @nacin5 years ago

  • Keywords needs-patch added; media detach unnattach removed
  • Milestone changed from Unassigned to Future Release

Seems sane to me. Looks like there is some consensus on that thread as well.

comment:2 @tomauger4 years ago

+1. Sounds like a patch has been made already and is just waiting for review and integration. Seems like it was an oversight not to include this. (Whenever you develop functionality that ADDS something, you must also develop the functionality that REMOVES that entity).

comment:3 @WraithKenny4 years ago

  • Cc Ken@… added

related #6820

comment:4 @C0BALT4 years ago

  • Severity changed from normal to major
  • Type changed from enhancement to defect (bug)

MEDIA UNATTACH, this is a serious bug.
+1

Very bad user-interface issue in my mind.
Because the option of unattach is not there, you hit delete thinking, it won't actually Delete the file, it'll just unattach it, and bam, it's very gone.

Question: If I have 7 images in the gallery, how do I "remove/unattach" one of those images without deleting it?
There is no "remove" or "X" or "unattach".
If you add a picture to post Y and you've already tweaked 7 meta parts of it and cropped it etc. and then realize it should've been in post Z you have to redo it.
Unless you are a programmer.

Personally, I've uploaded 60 photos to one site, and accidently attached 4 of them to the wrong post. The only solution I see now is to delete the 4 images, reload them and then hopefully attach them to the correct gallery upon reupload.

comment:5 @SergeyBiryukov3 years ago

  • Milestone Future Release deleted
  • Resolution set to duplicate
  • Status changed from new to closed

comment:6 follow-up: @bahia00199 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

I'd like to reopen this ticket. The previous resolution indicated that it was a duplicate, I looked at the ticket indicated, and it didn't address this issue.
This issue, as others above have mentioned, is a big sticking point. Slideshows that use attached images are a pain to update because even though deleted, they remain in the slideshow. To fix, users must go to the Media Library and permanently delete the images. It's not well thought out.

This impacts many people.

I think the default behavior for deleting a media item in a post or page should be to automatically remove it from the post. It make the most sense, since if you're deleting it, you no longer need it attached.

comment:7 in reply to: ↑ 6 @SergeyBiryukov9 months ago

  • Keywords close added; needs-patch removed
  • Milestone set to Awaiting Review

Replying to bahia0019:

I think the default behavior for deleting a media item in a post or page should be to automatically remove it from the post. It make the most sense, since if you're deleting it, you no longer need it attached.

See #27983. This ticket is still a duplicate of #6820. There's also a plugin for this.

comment:8 follow-ups: @bahia00199 months ago

This is not a duplicate. It may be related, but it's not a duplicate.
The description on the other ticket is "You should be able to change the parent of an attachment to attach it to a different post."

What this thread is about is being able to detach or unattach. Again, when deleting an image from a Page/Post/Gallery, it doesn't remove the association with that post. It's a huge oversight (as other above have mentioned).

And the plugin you refer to forces you to go to the Media Library to unattach the media. That's unintuitive and buggy at best.

All I'm saying is that the default behavior when deleting a Media attachment, is that it should unattach from that Post/Page.

comment:9 @MartyThornley9 months ago

I have to agree that this is not a duplicate of #6820. Very similar and maybe I am missing something but this is how I see them:

#14042 - When removing an image from the editor, it should be detached from the post also.
#6820 - We should be able to detach images and attach them to other posts.

Two related issues but very different patches to accomplish them.

comment:10 @kitchin9 months ago

A useful plugin is WP Better Attachments by Dan Holloran. On the Edit Page screen you get a meta box listing the attachments. You can detach, delete, add, and sort by drag and drop. The Twenty Fourteen front-end attachment page image.php almost necessitates use of this plugin on the back-end to keep the Previous / Next buttons accurate.

comment:11 in reply to: ↑ 8 ; follow-up: @DrewAPicture9 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from reopened to closed

Replying to bahia0019:

This is not a duplicate. It may be related, but it's not a duplicate.
The description on the other ticket is "You should be able to change the parent of an attachment to attach it to a different post."

The ticket description on #6820 is misleading. The patch attached there deals directly with adding Attach and Detach links and nothing more. I've updated the description, and this ticket is a duplicate.

And the plugin you refer to forces you to go to the Media Library to unattach the media. That's unintuitive and buggy at best.

All I'm saying is that the default behavior when deleting a Media attachment, is that it should unattach from that Post/Page.

Please raise any UX concerns in the other ticket.

Also, it's important to recognize the difference in terminology between "remove" and "delete". I think what you're referring to is that the default for "removing" an image from a post/page gallery should be to detach it.

Re-closing as a duplicate.

comment:12 in reply to: ↑ 8 ; follow-up: @SergeyBiryukov9 months ago

Replying to bahia0019:

Again, when deleting an image from a Page/Post/Gallery, it doesn't remove the association with that post. It's a huge oversight (as other above have mentioned).

That's not quite feasible, see 9:ticket:27983.

comment:13 in reply to: ↑ 12 @bahia00199 months ago

That's not quite feasible, see 9:ticket:27983.

Explain how that's not feasible please. What you referenced doesn't tell me why a media attachment can't be unattached. As you've pointed out, there are plugins to unattach. So why is it not feasible?


comment:14 in reply to: ↑ 11 ; follow-up: @bahia00199 months ago

The ticket description on #6820 is misleading. The patch attached there deals directly with adding Attach and Detach links and nothing more. I've updated the description, and this ticket is a duplicate.

OK, fine. But the patch that has been sitting there for 4 years deals with the just the Media Library. And it doesn't address the fact that there is no function inside the Edit Post/Page to unattach when you delete. That's a bug that really needs to be addressed, whether it's in this ticket, that ticket, whatever ticket.

Also, it's important to recognize the difference in terminology between "remove" and "delete". I think what you're referring to is that the default for "removing" an image from a post/page gallery should be to detach it.

What's the difference? Is there one? And yes, if you remove/delete an image from the post it should automatically detach from that Post/Page.

comment:15 in reply to: ↑ 14 @DrewAPicture9 months ago

Replying to bahia0019:

OK, fine. But the patch that has been sitting there for 4 years deals with the just the Media Library. And it doesn't address the fact that there is no function inside the Edit Post/Page to unattach when you delete. That's a bug that really needs to be addressed, whether it's in this ticket, that ticket, whatever ticket.

As I said, please feel free to raise any UX concerns over on the other ticket. That patch isn't yet a commit candidate and the discussion is still open for any additional functionality to be discussed.

Also, it's important to recognize the difference in terminology between "remove" and "delete". I think what you're referring to is that the default for "removing" an image from a post/page gallery should be to detach it.

What's the difference? Is there one?

There is a difference, "remove" removes it from the gallery, "delete" deletes the image.

I understand your expectation is that "remove" should be synonymous with "detach", though unfortunately we in aren't in a position to make that a reality in core. I'd argue the majority of users expect removing images from galleries to not detach images, just as much as they expect using [gallery] by itself to simply output images attached to the given post. We need to maintain the majority expectations in the spirit of backward compatibility.

As someone who is familiar with the various screens where adding attach/detach links would improve the experience. I invite you to share your perspective in the other ticket. We'd welcome your input.

comment:16 @Stagger Lee9 months ago

Just few words about those 2 detach plugins. (i found 2, maybe there is more but could not find them)
Non of them is working in post editing modal window. So they cannot be trusted with constant changing of core code for modal box.

Last edited 9 months ago by Stagger Lee (previous) (diff)
Note: See TracTickets for help on using tickets.