WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 9 months ago

Last modified 9 months ago

#14549 closed enhancement (duplicate)

Allow Control over Hard vs. Soft Rewrite Flush

Reported by: ikailo Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Rewrite Rules Keywords: has-patch
Focuses: Cc:

Description

Many times when the rewrite rules are flushed, it really only requires that the rules be written to the database and not .htaccess. In some cases, re-writing .htaccess can cause detrimental changes to the mod rewrite rules.

This patch allows a plugin author to have control over whether a hard flush is executed when flush_rewrite_rules() is called.

Introduces filter: flush_rewrite_rules_hard

Depends on #14546

Attachments (1)

filter_flush_rewrite_rules_hard.diff (550 bytes) - added by ikailo 5 years ago.
Moved filter to method

Download all attachments as: .zip

Change History (8)

comment:1 @ikailo5 years ago

  • Keywords has-patch added

comment:2 @ikailo5 years ago

  • Cc john@… added

comment:3 @nacin5 years ago

  • Keywords needs-patch 2nd-opinion added; has-patch removed

Any filter here should be in the method directly, not the function wrapper.

@ikailo5 years ago

Moved filter to method

comment:4 @ikailo5 years ago

  • Keywords has-patch added; needs-patch removed

comment:5 @markjaquith4 years ago

  • Milestone changed from Awaiting Review to Future Release

comment:6 @chriscct79 months ago

  • Keywords 2nd-opinion removed
  • Resolution set to duplicate
  • Status changed from new to closed

Implemented with different name in #23491

comment:7 @DrewAPicture9 months ago

  • Milestone Future Release deleted

Duplicate of #23491.

Note: See TracTickets for help on using tickets.