WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#14852 closed defect (bug) (invalid)

Newly published pages automatically becoming static home page

Reported by: bmeyer2 Owned by:
Milestone: Priority: normal
Severity: major Version: 3.0.1
Component: General Keywords: reporter-feedback
Focuses: Cc:

Description

I have a few basic static pages (Home, About Us, Contact Us, etc.). Home was the first static page created. Immediately afterwards, I set it as the static home page in Settings->Reading. This was working well. I then created a new page (About Us). The home page now displays About Us, even though the Home page's permalink remains at the root url.

Steps to reproduce:
1.) Create page
2.) Set homepage to "static page", selecting the page from #1
3.) Create any number of new pages
4.) On the front-end of the blog, navigate to the root url
5.) The newest page created will appear

This is on a fresh 3.0.1 install. I do not believe it to be an issue with templates, etc.

If it helps, I'm happy to supply the blog's URL, username, and password on request.

Thanks for any help!

Change History (4)

comment:1 bmeyer24 years ago

A little more info:

It's not simply the most recently updated page. I tried setting the homepage back to "recent posts", update the Home page, then set homepage back to static "Home". The root url still displays the most recently published page.

If I completely delete the Home page, re-create it, re-publish it, then re-set the homepage to the Home page, it works.

comment:2 mrmist4 years ago

This is normally down to a redirect plugin. Can't reproduce against trunk. Have you tried flushing permalinks (set permalinks to ugly and back)?

comment:3 dd324 years ago

  • Keywords reporter-feedback added

Cant reproduce this either on a 3.0/3.1 install

comment:4 nacin3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.