WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 10 months ago

#16725 closed defect (bug) (maybelater)

Inconsistent leading slash in WP_Rewrite

Reported by: scribu Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Rewrite Rules Keywords: needs-patch
Focuses: Cc:

Description

#16626 revealed an inconsistency in WP_Rewrite, where $wp_rewrite->front has a leading slash, but the final rules array doesn't.

This is caused by the fact that $wp_rewrite->permalink_structure itself has a leading slash.

Also note that $wp_rewrite->search_structure stands out as the only structure that doesn't have a leading slash.

This should be made consistent somehow.

Change History (2)

#1 @chriscct7
2 years ago

  • Type changed from enhancement to defect (bug)

Inconsistencies that need corrections are bugs aren't they?

#2 @chriscct7
10 months ago

  • Milestone Future Release deleted
  • Resolution set to maybelater
  • Status changed from new to closed

No traction in 5 years. Closing as maybe later.

Note: See TracTickets for help on using tickets.