WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#17178 closed defect (bug) (fixed)

Poor visibility of text in admin bar site list

Reported by: ericmann Owned by: westi
Milestone: 3.2 Priority: normal
Severity: normal Version: 3.1
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

After updating my network to 3.2-bleeding today, I noticed some strange styling in the My Sites dropdown of the admin bar. While other dropdown menus look just fine (typical, gray text) the site list text seems to be showing white-on-black embossed.

I've attached a screenshot to demonstrate.

This negatively affects the visibility and readability of the list, and since this is the only dropdown exhibiting this particular style, I'm guessing it's a bug.

Tested both on the front-end and the back end of WordPress using the Prose child theme for Genesis, the Lexicon child theme for Genesis, and Twenty Ten just for completeness' sake. Also tested in both Chrome (11.0) and Firefox-Aurora (5.0a2).

Attachments (4)

adminbar_visibility.png (21.7 KB) - added by ericmann 4 years ago.
17178.patch (406 bytes) - added by azaozz 4 years ago.
Can you confirm if this fixes it.
17178.hover.patch (470 bytes) - added by ocean90 4 years ago.
17178.2.patch (1.2 KB) - added by johnjamesjacoby 4 years ago.
Refresh, plus styling for strong tags

Download all attachments as: .zip

Change History (11)

@azaozz4 years ago

Can you confirm if this fixes it.

comment:1 follow-up: @ocean904 years ago

  • Keywords has-patch added; needs-patch ux-feedback removed
  • Milestone changed from Awaiting Review to 3.2

Related: #17107

comment:2 in reply to: ↑ 1 @ericmann4 years ago

Replying to [azaozz]:

Yes, that patch does fix the display issue.

comment:3 @azaozz4 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [17661]) Fix font color in admin bar site list, fixes #17178

comment:4 @ocean904 years ago

  • Resolution fixed deleted
  • Status changed from closed to reopened

The hover color is missing, patch will fix it.

@ocean904 years ago

@johnjamesjacoby4 years ago

Refresh, plus styling for strong tags

comment:5 @johnjamesjacoby4 years ago

Tested and confirmed 17178.hover.patch is good.

In 17178.2.patch, I added a fix for strong tags in menus as the font-weight gets set to normal for all menu elements further up the stack. I also added the :hover font styling to strong tags, since it previously was only applied to anchors and spans.

comment:6 @westi4 years ago

  • Owner set to westi
  • Resolution set to fixed
  • Status changed from reopened to closed

In [18097]:

Fix hover styles in the admin bar sites menu too. Fixes #17178 props ocean90 and johnjamesjacoby.

comment:7 @westi4 years ago

In [18098]:

Bump the version on the updated CSS. See #17178.

Note: See TracTickets for help on using tickets.