WordPress.org

Make WordPress Core

Opened 10 years ago

Closed 9 years ago

Last modified 8 years ago

#1727 closed defect (bug) (fixed)

broken gettext in PHP 4.4.0

Reported by: fredCZ Owned by:
Milestone: Priority: high
Severity: normal Version: 1.5.2
Component: General Keywords: gettext php 4.4.0 bg|squashed
Focuses: Cc:

Description

This part of code from gettext.php says everyting:

$MAGIC1 = (int)0x950412de; bug? in PHP 5
$MAGIC1 = (int) - 1794895138; bug? in PHP 4.4.0
$MAGIC1 = 2500072158; works with PHP 4.4.0 but no tested anywhere else

$MAGIC2 = (int)0xde120495; bug?
$MAGIC2 = (int) - 569244523; bug? in PHP 4.4.0
$MAGIC2 = 3725722773; works with PHP 4.4.0 but no tested anywhere else

Change History (8)

comment:1 @masquerade10 years ago

That clearly says that it "works with PHP 4.4.0" and gettext is working fine here, if someone else can confirm its working fine, mark this as invalid.

comment:2 @markjaquith10 years ago

  • Keywords bg|squashed added
  • Resolution set to worksforme
  • Status changed from new to closed

Works for me. PHP 4.4.0

comment:3 @ryan9 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Confirmed on 4.4.2 for 64 bit machine.

comment:5 @ryan9 years ago

  • Milestone set to 2.0.4

comment:6 @ryan9 years ago

  • Resolution set to fixed
  • Status changed from reopened to closed

(In [4003]) Update to php-gettext 1.0.7+. fixes #1727

comment:7 @ryan9 years ago

(In [4004]) Update to php-gettext 1.0.7+. fixes #1727

comment:8 @anonymous8 years ago

  • Milestone 2.0.4 deleted

Milestone 2.0.4 deleted

Note: See TracTickets for help on using tickets.