WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#18978 closed defect (bug) (duplicate)

rewrite_rules

Reported by: obscurecloud Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Rewrite Rules Keywords:
Focuses: Cc:

Description (last modified by SergeyBiryukov)

This may or may not be the place for this.
I've seen this issue debated in another ticket and it's marked resolved.
I'd like to put a different point of view into the debate.

I have a site with 2800 pages and growing by about 20 per day.
The size of the wp_options filed rewrite_rules (3MB and 3,000,000 characters in this one field)) was crashing my server consistently until I changed the permalink structure.

It recently crashed my server due to the permalink structure of category/postname and was very hard to track down that this was the cause. The severity of the problem and ease of reproducing should garner some attention to this issue.

First I'd like to point that while you all know that this is not the best way to do it for performance reasons, that info is not readily available to the average web developer using WordPress.

My fist suggestion is that if you don't change the way WP stores the rewrite rules, you put a notice on the permalink page about the performance issues of this type of permalink.

My second suggestion is that this type of permalink structure be better supported for obvious reasons. It's popular, easy to read, and many people believe it enhances SEO. WordPress is used as a CMS more often these days.

Change History (2)

comment:1 SergeyBiryukov3 years ago

  • Description modified (diff)

comment:2 dd323 years ago

  • Component changed from General to Rewrite Rules
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

The ticket you probably read was #16687 - Which has been fixed in the upcoming 3.3 release. 3.3 Beta1 is out, with the final release in November.

Permastructures using %category% and/or %postname% at the start have long been suggested against for the performance issues which you've come up against, That'll be resolved in the next release thanks to the above.

(FYI, It's possible to leave comments on closed tickets, both new and old, Developers will see the updates through the mailing lists)

Closing as a duplicate of #16687

Note: See TracTickets for help on using tickets.