WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

#19333 closed defect (bug) (worksforme)

Permalink 403 Error When Using an Old Permalink URL

Reported by: eriknokc Owned by:
Milestone: Priority: normal
Severity: critical Version: 3.2.1
Component: Permalinks Keywords: reporter-feedback close
Focuses: Cc:

Description

Yesterday I deleted a page and recreated it so that the Permalinks would use the same URL. Users received the following error...

"Forbidden

You don't have permission to access /blog/text-message-alerts/ on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request."

I tried this a couple of times with different old Permalink URLs and received the same error. On any of these pages, if I turn off Permalinks, the GUID URL works fine.

Finally, I created a page so that the Permalinks URL was different from anything that had been created before and the Permalink worked fine. I changed the Title of the page to match the title of the old page after I had published the page and everything still works fine.

I have also reviewed the htaccess file and everything is as originally setup by Wordpress.

It appears that Wordpress is having an issue reusing old Permalinks and will not allow it to happen.

Change History (4)

comment:1 @SergeyBiryukov3 years ago

  • Keywords reporter-feedback added

Make sure you delete the pages permanently from Trash. Otherwise, new page would have a slug ending with a number: /blog/text-message-alerts-2/.

comment:2 @eriknokc3 years ago

The trash is clear. I make sure to move to trash and them empty the trash and I still experience these issues.

comment:3 @dd323 years ago

  • Keywords close added; needs-patch removed

WordPress doesn't generate 403 errors such as that, specifically, it sounds like your server is blocking access to the URL before PHP/WordPress is even given the request.

Check your server logs and see what's being logged as the cause.

comment:4 @SergeyBiryukov3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.