WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#19943 closed defect (bug) (invalid)

Jetpack does not work globally on multisite - Shows stats from main site on sub-sites

Reported by: Sadr Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Multisite Keywords:
Focuses: Cc:

Description

This missing feature, and the bugs associated with it due to its inability to deny invalid use cases, has been in existence for almost a year now, ever since WordPress Stats was introduced to Jetpack:
http://wordpress.org/support/topic/plugin-jetpack-by-wordpresscom-jetpack-on-multi-site
http://wordpress.org/support/topic/jetpack-and-multisite-wrong-stats-being-shown

Activating Jetpack+stats network-wide on multisite will result in stats tracing for the main blog only. This is very inconvenient for site owners using multisite to manage several sites as smaller part of one large website. At the very least, as long as this unintended behaviour is present, the plugin should disallow Jetpack Stats being active (with the same authentication) on more than one blog at a time.

Ideally, upon network activation the admin would have two options:

  • 1 - Activate Jetpack with shared authentication across all blogs
  • 2 - Activate Jetpack with independent authentication per blog.

I realize the responsibility of this plugin does not rest on the WP core developers' shoulders, but Jetpack is undeniably a hugely important plugin for WordPress. Maybe there are changes that can be done in WordPress Multisite that will make the Jetpack integration easier.

Change History (2)

comment:1 ocean902 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from new to closed

You should contact http://jetpack.me/support/.

comment:2 scribu2 years ago

As ocean90 said, even if it was on the WP Core developer's shoulder's, core.trac is not the appropriate place to handle this issue.

Note: See TracTickets for help on using tickets.