WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 9 months ago

#20178 closed enhancement (duplicate)

wpdb class : provide a disconnect / connect to db functions

Reported by: arena Owned by: arena
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Database Keywords: close
Focuses: Cc:

Description

some hosts automatically disconnect mysql after a short while.
I think it could be interesting to have in wpdb a disconnect and connect functions.

Change History (6)

comment:1 @ocean903 years ago

  • Summary changed from enhancement : wpdb class : provide a disconnect / connect to db functions to wpdb class : provide a disconnect / connect to db functions

Related: #5932

comment:2 @arena3 years ago

Hi ocean90

the code i am currently using

class data_base
{
	function mysql_disconnect()
	{
		global $wpdb;
		mysql_close($wpdb->dbh);
	}

	function mysql_connect()
	{
		global $wpdb;
		$wpdb->__construct(DB_USER, DB_PASSWORD, DB_NAME, DB_HOST);
	}
}

but still have some "mysql_real_escape_string(): nn is not a valid MySQL- Link resource" on some webhosts after disconnecting/connecting !

comment:3 @nacin19 months ago

  • Component changed from General to Database

comment:4 @pento18 months ago

  • Keywords close added; dev-feedback removed

Unless there's another use case for this, I'm inclined to close this ticket. The reported bug (hosts automatically disconnecting MySQL) will be fixed by #5932.

comment:5 @arena18 months ago

Not sure to close this ticket is a good option.
At least wordpress to privide an api in fixing #5932.
Some plugins may use it ...

comment:6 @pento9 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #5932.

If the MySQL connection is lost mid-page load, it will reconnect as of [27279].

For more advanced connecting/disconnecting, this is the realm of a drop-in DB replacement.

Note: See TracTickets for help on using tickets.