WordPress.org

Make WordPress Core

Opened 2 years ago

Closed 2 years ago

#20209 closed defect (bug) (invalid)

User with "author" role can publish his posts without admin permition

Reported by: egorpromo Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Administration Keywords:
Focuses: Cc:

Description

I am admin of site. I create new user with role "Author". This new user can publish his own posts and custom posts (which were created by register_post_type() function).

I think it is incorrect if user with "Author" role can publish his posts and custom posts without admin permision.

May be it is bug?

Change History (2)

comment:2 dd322 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

By design. Authors can Publish posts/pages/CPT's, Contributors can write articles, however it must be approved before publishing.

For CPT's, you can specify different permissions by using the capabilities option when registering the post type. (see the codex)

The Capability vs. Role table in the codex is a good visual example of which each role can do by default.

Note: See TracTickets for help on using tickets.