WordPress.org

Make WordPress Core

Opened 9 years ago

Closed 5 years ago

#20288 closed enhancement (worksforme)

Missing bottom border for bulk-actions checkbox th in wp-posts-list-table if current user can't "edit_post".

Reported by: szaqal21 Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.3.1
Component: Posts, Post Types Keywords: has-patch reporter-feedback close
Focuses: ui, administration Cc:

Description (last modified by helenyhou)

If current user can't "edit_post" the bulk-actions checkbox isn't present but also the bottom border for th in wp-posts-list-table.

I think it can be fixed by modifying line 495 in class-wp-posts-list-table.php like so:

<th scope="row" class="check-column"><?php if ( $can_edit_post ) { ?><input type="checkbox" name="post[]" value="<?php the_ID(); ?>" /><?php } else { ?> &nbsp; <?php } ?></th>

Attachments (2)

20288.patch (666 bytes) - added by SergeyBiryukov 8 years ago.
20288.bottom-border.png (8.4 KB) - added by SergeyBiryukov 8 years ago.

Download all attachments as: .zip

Change History (10)

#1 @szaqal21
9 years ago

  • Keywords has-patch added; needs-patch removed

#2 @helenyhou
9 years ago

  • Description modified (diff)
  • Keywords needs-patch added; has-patch removed

Patches should be made and attached as a unified diff created from root. Helpful links:

Mark Jaquith's Unix WordPress Toolbox

Peter Westwood's Windows WordPress Toolbox

#3 @SergeyBiryukov
8 years ago

  • Keywords has-patch reporter-feedback added; needs-patch removed

The patch just adds &nbsp.

However, I couldn't reproduce the missing bottom border issue in Firefox 11, Chrome 18, IE 8, or Opera 11.61 (see the screenshot). Which browser are you using?

#4 @DrewAPicture
8 years ago

  • Component changed from UI to Administration

#5 @DrewAPicture
8 years ago

  • Keywords ui-focus added

#6 @jeremyfelt
7 years ago

  • Component changed from Administration to Posts, Post Types
  • Focuses admin added

#7 @szaqal21
6 years ago

  • Keywords close added

Issue fixed.

#8 @wonderboymusic
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.