WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 5 years ago

#20825 closed defect (bug) (worksforme)

User activation in multisite should happen in the main blog..

Reported by: rahal.aboulfeth Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.0
Component: Login and Registration Keywords: has-patch
Focuses: multisite Cc:

Description

In multisite mode ( subdomain ) , when a user activates his account, it should happen in the main blog ( or not ? ) .

In ms-settings.php ( line 118 ) , we assume that the main blog is always blog=1 ( which may be wrong ) .

The attached patch uses the constant BLOG_ID_CURRENT_SITE if defined instead.

Attachments (2)

main-blog-while-activation-user.patch (640 bytes) - added by rahal.aboulfeth 7 years ago.
20825.diff (672 bytes) - added by jeremyfelt 6 years ago.

Download all attachments as: .zip

Change History (8)

#1 in reply to: ↑ description @wpmuguru
7 years ago

Replying to rahal.aboulfeth:

In multisite mode ( subdomain ) , when a user activates his account, it should happen in the main blog ( or not ? ) .

This works the same as MU did. Activation in a subdomain install occurred at the subdomain address. We may want to change that. Just noting that it's not a bug.

@jeremyfelt
6 years ago

#2 @jeremyfelt
6 years ago

  • Keywords dev-feedback added
  • Milestone changed from Awaiting Review to 3.7
  • Version set to 3.0

20825.diff is a refreshed patch against trunk. Moving to 3.7 for discussion.

#3 @nacin
6 years ago

  • Milestone changed from 3.7 to Future Release

This works the same as MU did. Activation in a subdomain install occurred at the subdomain address. We may want to change that. Just noting that it's not a bug.

#4 @jeremyfelt
6 years ago

  • Keywords close added

Looking at the patch and behavior again, the $blog_id is only set to 1 in ms-settings.php when WP_INSTALLING is defined. This should only happen during the first multisite setup and is likely appropriate.

I'm not sure that anything should change here.

#5 @jeremyfelt
6 years ago

  • Component changed from Multisite to Login and Registration
  • Focuses multisite added

#6 @jeremyfelt
5 years ago

  • Keywords dev-feedback close removed
  • Milestone Future Release deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Closing this out. Feel free to reopen if this is a concern, but it appears that things work as intended.

Note: See TracTickets for help on using tickets.