WordPress.org

Make WordPress Core

#21535 closed defect (bug) (worksforme)

Featured images no longer appear after wordpress update

Reported by: ajay423 Owned by: ajay423
Milestone: Priority: normal
Severity: normal Version: 3.4.1
Component: Media Keywords: reporter-feedback
Focuses: Cc:

Description

The issue we faced is when the current version of WordPress was updated to the latest one i.e. 3.4.1 . The problem faced has been notified as bug in the latest version of the WordPress. The Featured Images which we have in our site was no longer available, The path was fine but image is not available. so we need to upload all the images to the media library again. Can we please have a solution for this as we cant upload thousands of images to each and every post every time we update our WordPress. Hope the future versions of WordPress doesn't repeat this issue.

Change History (7)

comment:1 knutsp21 months ago

  • Cc knut@… added
  • Component changed from General to Media
  • Keywords close added
  • Resolution set to worksforme
  • Severity changed from major to normal
  • Status changed from new to closed
  • Type changed from feature request to defect (bug)

Featured images on posts works perfectly in WordPress 3.4.1, also after upgrade from 3.4.

Deactivate all plugins and activate the default theme. If the problem persists, the place to get help is http://wordpress.org/support/

If you still have a reason to believe this is a bug in WordPress core, please reopen this ticket and provide steps to reproduce this bug on a clean install, or in an upgrade situation. Please, also clarify what you mean by "not available". Did the featured image just disappear from your old posts, and/or are some images not to be found in the media library? Answers to these questions will be useful for anyone who wants to help.

comment:2 SergeyBiryukov21 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted

If you're using Auto Post Thumbnail plugin, that might be it.

It was recently updated for 3.4, and the changelog includes a link to the script for updating thumbnails in existing posts.

The related changeset is [20613]: get_attached_file() now only returns the file name if the file actually exists, relying on the correct _wp_attached_file value in the database.

comment:3 ajay42320 months ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

I have Tried Deactivating all the plugins and activating them again, but that didn't work.
Problem area --> I am having featured images set for many posts in my WordPress, and it is a multisite network. When i update my WordPress to 3.4.1 80% of my featured images are not appearing on my website. The problem is in all the sites except my home site. The images are there in my media library, but when i open in my post the featured image is not available there. It is working fine when i re-upload images to my post.

I not using any plugins for the featured image.

comment:4 SergeyBiryukov20 months ago

  • Milestone set to Awaiting Review

comment:5 Ipstenu20 months ago

Do the normal theme check, but you're the only person I've heard of having this issue, and a lot of people use Multisite, so the odds are against it being a bug in WP, and more that it's your site :/

(Normal theme check being - please switch the sub sites to twenty eleven and see if they start working,)

comment:6 SergeyBiryukov17 months ago

  • Keywords reporter-feedback added

comment:7 SergeyBiryukov17 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from reopened to closed

Please try the support forums for troubleshooting: http://wordpress.org/support/

Feel free to reopen with steps to reproduce on a clean install if it turns out to be a bug in core.

Note: See TracTickets for help on using tickets.