WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 6 years ago

#21577 closed defect (bug) (fixed)

Twenty Twelve: IOS Zoom bug

Reported by: bradthomas127 Owned by:
Milestone: 3.5 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

Testing with iPad2 5.1.1 i noticed i was getting the iOS zoom bug on orientation change.

I was able to fix this by removing initial-scale=1
from the viewport, i did some digging around on this and noticed that it was removed from html5 boilerplate about 7 months ago because of this: https://github.com/h5bp/html5-boilerplate/commit/26d6be247987741b92c83bae2f47111b43a6f1f2

Issue: https://github.com/h5bp/html5-boilerplate/issues/824

Attachments (1)

21577.diff (646 bytes) - added by obenland 7 years ago.

Download all attachments as: .zip

Change History (9)

@obenland
7 years ago

#1 @obenland
7 years ago

  • Keywords has-patch added

Reproduced with Safari on iPad3. Chrome seems to be fine though. Patch fixes it, as promised. Patch tested positively with iOS 5.1.1 Safari & Chrome and some ridiculously old HTC Android that I can't wait to get rid of.

#2 @lancewillett
7 years ago

  • Cc lancewillett added
  • Milestone changed from Awaiting Review to 3.5

#3 @bradthomas127
7 years ago

Thanks obenland I forgot to mention this was happening in Safari.

Off the subject, i noticed a double line-height in the stylesheet lines: 1255 & 1256.

#4 @lancewillett
7 years ago

In [21520]:

Twenty Twelve: selector for navigation menu should style the menu list element, props obenland, see #21562.

Also remove duplicate line-height rule, props bradthomas127. See #21577.

#5 @lancewillett
7 years ago

In [21525]:

Twenty Twelve: remove initial-scale value from viewport meta element to avoid iOS zoom bug. Props bradthomas127, see #21577.

#6 @lancewillett
7 years ago

  • Keywords needs-testing removed
  • Resolution set to fixed
  • Status changed from new to closed

#7 @lancewillett
7 years ago

A bunch more discussion on Github project: https://github.com/h5bp/html5-boilerplate/issues/1099

Adding here for future reference.

Apparently this will be fully fixed in iOS 6. Woot.

Note: See TracTickets for help on using tickets.