WordPress.org

Make WordPress Core

Opened 19 months ago

Closed 8 weeks ago

#22051 closed defect (bug) (worksforme)

Turning off italic at the end of the word de-italicizes whole word.

Reported by: cheekyboots Owned by:
Milestone: Priority: normal
Severity: minor Version: 3.4.2
Component: TinyMCE Keywords:
Focuses: Cc:

Description

I'm on a mac so I am using command-I to turn on italics in the post editor, visual mode, as I write.

To replicate: Write the first letter of a word. Then backspace. Then press command-I, and write the whole word, which will now be italicized. Before pressing the space bar, hit command-I again. Instead of just turning off italics for your next word, it turns the word you just wrote back into non-italicized text.

Through testing I discovered that it does not happen if you press command-I at the beginning of the word, it only happens when you back up in the middle of the word and then press command-I. And it doesn't happen when you press the "I" italics toolbar button to turn italics on and off, it only happens when using the keyboard shortcuts.

This is new behavior that started with one of the recent updates, but I don't know which one.

I know it's not a huge bug, but it's not expected behavior and it really gets in the way of my typing flow. I have to stop, go back to select the word, and make it italic again.

Change History (2)

comment:1 nacin19 months ago

  • Component changed from Editor to TinyMCE

comment:2 ocean908 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hello cheekyboots, thanks for the report and sorry you never got a response.

We have recently updated TinyMCE to version 4 (#24067). I tested you steps in Chrome, Firefox and IE and couldn't reproduce it anymore.

Note: See TracTickets for help on using tickets.