WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 11 months ago

#22226 closed enhancement (duplicate)

Duplicate Terms in Custom Taxonomies

Reported by: mojowill Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4.2
Component: Taxonomy Keywords:
Focuses: Cc:

Description

You are unable to add duplicate terms with the same slug, this makes sense. However when creating custom taxonomies you should be able to create terms with duplicate slugs as long as they are in a different taxonomy.

For example:

My blog has a tag called WordPress.
I can have a category called WordPress (

I cannot however create a tag called WordPress in my own custom taxonomy "Skills". This is a custom taxonomy setup with hierarchical set to false, like tags.

Would it not make sense to allow this?

Change History (4)

comment:1 in reply to: ↑ description ; follow-up: @johnbillion3 years ago

Not quite sure what you mean by this:

I cannot however create a tag called WordPress in my own custom taxonomy "Skills".

Regardless, this is probably a duplicate of #5809.

comment:2 in reply to: ↑ 1 @mojowill3 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

Replying to johnbillion:

Not quite sure what you mean by this:

I cannot however create a tag called WordPress in my own custom taxonomy "Skills".

Regardless, this is probably a duplicate of #5809.

I was referring to not being able to duplicate terms in separate taxonomies. I'm happy to close and watch #5809 to see if that patch works.

comment:3 @helenyhou3 years ago

  • Milestone Awaiting Review deleted

comment:4 @ocean9011 months ago

#29131 was marked as a duplicate.

Note: See TracTickets for help on using tickets.