WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 7 weeks ago

#22857 closed enhancement (fixed)

'Header Image' state isn't removed from images previously used as header image

Reported by: johnbillion Owned by: johnbillion
Milestone: 4.7 Priority: normal
Severity: normal Version: 3.4.2
Component: Customize Keywords: has-patch needs-testing
Focuses: ui, administration Cc:

Description (last modified by johnbillion)

Steps to reproduce:

  1. Set your site's header image from Appearance -> Header by uploading an image or choosing one from your media library.
  2. Repeat step 1.
  3. Visit the Media Library and note that your previous header image still says 'Header Image' next to it.

Not a 3.5 regression as it happens in 3.4.2 too.

Attachments (5)

22857.patch (1.3 KB) - added by deltafactory 3 years ago.
Add Current Header/Background image identifier
22857.2.diff (1.7 KB) - added by coreymcollins 2 years ago.
Above fixes and: removed redundant "Header Image" text on "Current Header Image"
Screenshot 2014-12-08 10.27.08.png (45.7 KB) - added by coreymcollins 2 years ago.
Removed redundant "Header Image" text when displaying "Current Header Image"
Screen Shot 2016-10-03 at 2.10.32 PM.png (76.5 KB) - added by desrosj 2 months ago.
22857.diff (2.0 KB) - added by desrosj 2 months ago.
Improve the patch to fix the problem, and the scenario I described earlier. There was also a stray echo in the first patch that I removed.

Download all attachments as: .zip

Change History (26)

#1 @johnbillion
4 years ago

  • Description modified (diff)

Affects background images too.

#2 @SergeyBiryukov
4 years ago

  • Component changed from Media to Appearance

#3 @deltafactory
3 years ago

As used by get_uploaded_header_images() and on the Appearance -> Header page, the intention of the Header Image label indicates that the current theme had used it as a header image at one time. It's used to provide a list of previous images to select quickly.

What about a separate indicator via _media_states() that shows the "Current Header Image" status?

#4 @deltafactory
3 years ago

  • Cc jeff@… added

#5 @ocean90
3 years ago

  • Keywords needs-patch added
  • Type changed from defect (bug) to enhancement

deltafactory is right.

I like the idea of "Current Header Image", let's try this.

@deltafactory
3 years ago

Add Current Header/Background image identifier

#6 @deltafactory
3 years ago

  • Keywords has-patch added; needs-patch removed

Looks like I had worked on this back then.. Patch provided.

#7 @deltafactory
3 years ago

  • Focuses ui administration added

As provided, the patch leaves the "Header Image" and adds "Current Header Image" which is redundant. Is there value to adding to the status, or replacing it?

#8 @samuelsidler
3 years ago

  • Keywords needs-testing added

@coreymcollins
2 years ago

Above fixes and: removed redundant "Header Image" text on "Current Header Image"

@coreymcollins
2 years ago

Removed redundant "Header Image" text when displaying "Current Header Image"

#9 @celloexpressions
23 months ago

  • Milestone changed from Awaiting Review to Future Release

#10 @karmatosed
4 months ago

I think this solution works if as simply adds a new state that makes sense. I can see this being really useful information to a user. Great idea.

#11 @johnbillion
3 months ago

  • Milestone changed from Future Release to 4.7

#12 @jorbin
3 months ago

@johnbillion Since you milestoned this, what are you thinking? Is the current patch ready to go in or does it need some changes?

This ticket was mentioned in Slack in #core-customize by celloexpressions. View the logs.


2 months ago

This ticket was mentioned in Slack in #core-customize by celloexpressions. View the logs.


2 months ago

#15 @desrosj
2 months ago

The patch fixed the problem for me, except under one scenario. If you perform the steps above to have multiple header images on the site, and then select "randomize uploaded headers", no images receive "Current Header Image". Only one of the uploaded headers says "Header Image", at random. All of the images should say "Header Image". Incoming screenshot.

#16 @celloexpressions
2 months ago

  • Owner set to johnbillion
  • Status changed from new to assigned

@desrosj
2 months ago

Improve the patch to fix the problem, and the scenario I described earlier. There was also a stray echo in the first patch that I removed.

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


2 months ago

#18 @johnbillion
2 months ago

  • Status changed from assigned to reviewing

This ticket was mentioned in Slack in #core by jeffpaul. View the logs.


2 months ago

This ticket was mentioned in Slack in #core by desrosj. View the logs.


8 weeks ago

#21 @johnbillion
7 weeks ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 38831:

Customize: Improve the labelling of background and header images in the list mode of the media library.

Props deltafactory, coreymcollins, desrosj
Fixes #22857

Note: See TracTickets for help on using tickets.