WordPress.org

Make WordPress Core

#23818 closed defect (bug) (fixed)

Twenty Thirteen: improve separation between Link and Aside posts

Reported by: lancewillett Owned by:
Milestone: 3.6 Priority: normal
Severity: normal Version: 3.6
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

When viewing Link + Asides posts on index views the posts tend to blend together because they use the same background colors.

See http://siobhanmckeown.com/ for an example.

Screenshot attached.

IRC log of her report.

Attachments (4)

siobhan-home.png (329.7 KB) - added by lancewillett 13 months ago.
23818.diff (703 bytes) - added by MikeHansenMe 13 months ago.
Possible Solution
colors.png (143.4 KB) - added by MikeHansenMe 13 months ago.
screenshot of patch
23818.1.diff (1.2 KB) - added by lancewillett 13 months ago.

Download all attachments as: .zip

Change History (13)

lancewillett13 months ago

comment:1 lancewillett13 months ago

Discussed today with Joen; he is going to work on a quick visual separator to fix this.

comment:2 bpetty13 months ago

  • Keywords needs-patch removed
  • Milestone 3.6 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

It was already decided to stick with the original colors, see #23707

comment:3 obenland13 months ago

  • Keywords needs-patch added
  • Milestone set to 3.6
  • Resolution wontfix deleted
  • Status changed from closed to reopened
  • Version set to trunk

It's not about the colors. It's about the margin.

comment:4 lancewillett13 months ago

As mentioned by @bpetty, this is related to #23707.

comment:5 bpetty13 months ago

Nothing in this ticket or #23707 mentioned "margin" once. Both are caused by the fact that those post format combinations use the same background color (as the OPs mentioned in both).

There's three possible resolutions to this:

  1. Add in additional post format colors so each have their own. There is a finite number of formats, so this really would be reasonable.
  2. Add in some new border style. Doesn't matter what it looks like, could be solid line separator, a drop shadow, or whatever, just as long as it provides some indication that you're looking at the next post.
  3. Leave it how it is. It's a rare circumstance in the first place, and this was how the theme was designed. It's a minor issue that's easily worked around in the post itself. Usually the post date after each link is the end of the post, without a full description of the link (like this screenshot - which really abuses the "link" post format for a regular post).

In all cases, this ticket is not just "related", it's a duplicate of #23707, where a decision was made to leave it. If you want to revisit that, the appropriate action is to re-open #23707, and discuss it there, especially since that also happens to be where sabreuse first reported that this was the case with the Link + Aside combination, and she deserves some follow-up to her comments on that ticket if anything actually does happen with this.

MikeHansenMe13 months ago

Possible Solution

MikeHansenMe13 months ago

screenshot of patch

comment:6 lancewillett13 months ago

Let's allow the theme designer some room to work on a solution. :)

I'll update the ticket once he's proposed a working method. Probably will be along the lines of:

  1. Doesn't matter what it looks like, could be solid line separator, a drop shadow, or whatever, just as long as it provides some indication that you're looking at the next post.

... from above, mentioned by bpetty.

Last edited 13 months ago by lancewillett (previous) (diff)

lancewillett13 months ago

comment:7 lancewillett13 months ago

  • Keywords has-patch added; needs-patch removed

.1.diff is proposed CSS solution from Joen — minimal separators between reoccurring posts in aside + link and audio + video.

comment:8 lancewillett13 months ago

Chatting with Joen and Obenland more on this approach -- we're going to do this for aside and links but not for video and audio.

Separator should be applied in the following 3 cases:

  1. Aside + Aside
  2. Aside + Link
  3. Link + Aside

comment:9 lancewillett13 months ago

  • Keywords has-patch removed
  • Resolution set to fixed
  • Status changed from reopened to closed

In [23785] Twenty Thirteen: improve separation between Link and Aside posts, props Joen for starter CSS rules. Fixes #23818 and closes #23707 as related.

Note: See TracTickets for help on using tickets.