Make WordPress Core

Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#24191 closed defect (bug) (duplicate)

Open Tags before <!--nextpage--> impacts entire webpage

Reported by: crushgear Owned by:
Milestone: Priority: normal
Severity: minor Version: 2.5
Component: Formatting Keywords:
Focuses: Cc:


If a chunk of your post is formatted (like strong or em) and you insert the <!--nextpage--> tag after an open formatting tag, it will actually format the rest of your entire page (comments, sidebar, etc.) with the tag.

I was able to replicate this bug on trunk in both Chrome and Firefox.

Here's an example of content that would trigger this bug:

<strong>Testing the nextpage bug <em>


tag bug. </strong></em>

Change History (3)

#1 @johnbillion
3 years ago

Sounds like we need to run force_balance_tags() on the content that comes before <!--nextpage--> when it's displayed on its own.

#2 @SergeyBiryukov
3 years ago

  • Component changed from TinyMCE to Formatting
  • Milestone Awaiting Review deleted
  • Status changed from new to closed
  • Version changed from trunk to 2.5

Duplicate of #6297.

#3 @SergeyBiryukov
3 years ago

  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.