WordPress.org

Make WordPress Core

#24382 closed defect (bug) (duplicate)

network_site_url returns incorrect value for Multisite subdirectory install

Reported by: creativeinfusion Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Multisite Keywords:
Focuses: Cc:

Description

network_site_url() does not return the location of the WordPress install for Multisite subdirectory installations

  1. Install WordPress to its own directory (e.g. wordpress)
  2. Install network as subdirectory.
  3. Add a subsite (so we have main site and subsite).

network_site_url() returns the same value as network_home_url() when it should be different, i.e. it always returns http://domain.com rather than the expected http://domain.com/wordpress

For information, site_url and home_url return as follows:

main site subsite
site_url http://domain.com/wordpress http://domain.com/subsite
home_url http://domain.com http://domain.com/subsite

Note that the unexpected behaviour of site_url for the subsite seems to be by design (see comment:43:ticket:19796 and comment:78:ticket:19796).

Change History (3)

comment:1 SergeyBiryukov14 months ago

Appears to be a duplicate of #23221.

comment:2 nacin14 months ago

I've removed the invalid designation from #23221 — what you are seeing is by design.

comment:3 SergeyBiryukov14 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #23221.

Note: See TracTickets for help on using tickets.