WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#25989 closed defect (bug) (duplicate)

In Quick Edit view, old slug is not saved when changing URL slug

Reported by: markowe Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.1
Component: Permalinks Keywords:
Focuses: Cc:

Description

As I understand it, when you edit a page/post in the normal editor view, and change the URL slug, the previous slug will be saved to postmeta for the purposes of correctly redirecting to the new permalink.

This works fine in the regular editor view, but when using the Quick Edit facility in the Pages/Posts list view it does not appear to work.

Procedure attempted:

1) Quick Edit Page.
2) Change Page slug from, e.g. "blue-widgets-in-arizona" to "arizona"
3) Press Update

Expected behaviour: mysite.com/blue-widgets-in-arizona should redirect to mysite.com/arizona (works in full edit view)

Actual behaviour: 404 error on page mysite.com/blue-widgets-in-arizona.

Change History (3)

#1 @markowe
7 years ago

  • Keywords needs-testing removed

#2 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 3.7.1 to 2.1

The old slug redirect feature only works for posts, not for pages (see #4328, #18318).

I've tested Quick Edit for posts in current trunk, and the redirect works correctly (see #12473 where it was fixed).

Closing as a duplicate of #4328.

#3 @markowe
7 years ago

OK, didn't come across that one - so we are not likely to see this implemented for pages. I guess the message is, one shouldn't rely on Wordpress to automatically redirect changed permalinks.

Note: See TracTickets for help on using tickets.