WordPress.org

Make WordPress Core

Opened 3 years ago

Closed 7 days ago

#26349 closed defect (bug) (worksforme)

Network Admin links are inconsistent

Reported by: rmccue Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Networks and Sites Keywords: needs-patch good-first-bug
Focuses: multisite Cc:

Description

If you have WP in a subdirectory (say wp/) and don't set define('PATH_CURRENT_SITE', '/wp/');, the Network Admin links are inconsistently broken for a subdomain install.

For example, on the Sites page (network/sites.php), the menu links incorrectly to /wp/wp-admin/network/site-new.php, however the links on the page itself link to /wp-admin/network/site-new.php

I'm guessing that the links on the page don't use network_admin_url(). Let's at least be consistently wrong here.

Change History (11)

#1 @jeremyfelt
3 years ago

  • Component changed from Multisite to Permalinks
  • Focuses multisite added

#2 @jeremyfelt
3 years ago

  • Keywords needs-patch added
  • Milestone changed from Awaiting Review to Future Release

I've run into link weirdness plenty of times as well. We should clarify current behavior and then make sure it is consistent and expected.

#3 @SergeyBiryukov
3 years ago

  • Component changed from Permalinks to Networks and Sites

#4 @boonebgorges
2 years ago

  • Keywords good-first-bug added

This ticket was mentioned in Slack in #core by ianmjones. View the logs.


2 years ago

#6 @ianmjones
2 years ago

I have tried everything I can to reproduce this bug, including subverting setup to go against the way WordPress tries to steer any sub-directory install away from subdomain network setup, but I am simply unable to reproduce the problem.

I'm thinking that it has been fixed somewhere since 3.5.

If I'm wrong, and it can be reproduced in version 4.1 some steps to reproduce would be great.

#7 @Yahire Furniture
2 years ago

Yes this is not happening on latest version for me. It happened before I done the latest update.

#8 @neverything
18 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

Tested in 4.1 with a multisite in /wp/ and subdomains. Couldn't reproduce this issue.

#9 @ocean90
18 months ago

  • Milestone Future Release deleted

#10 @kyl
8 days ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

The links in the 'Network Admin' menu point to the wrong directory in my installation (Wordpress 4.6.1) where Wordpress is located in its own directory and multisite is enabled, i.e. siteurl <> home. E.g. the link behind the menu item 'My Sites' / 'Network Admin' / 'Dashboard' on the page http://example.com/wordpress/wp-admin/network/ reads "http://example.com/wp-admin/network/", resulting in HTTP 404 when I choose it.

#11 @kyl
7 days ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

Sorry, in the meantime I found out it was my fault. I confused "WordPress Address (URL)" and "Site Address (URL)". By the way, I didn't find a way to recover from this error than to completely reinstall Wordpress.

Note: See TracTickets for help on using tickets.