WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#26789 closed defect (bug) (worksforme)

Permalinks broken on fast page publish

Reported by: kutija Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8
Component: Administration Keywords:
Focuses: Cc:

Description

Description
This bug affects permalinks of all pages with names made from few words.

Steps to reproduce

  1. Go to Add New Page
  2. Enter the page title (i.e Pay as you go)
  3. Wait until Wordpress gives it a permalink
  4. While still in the Editor, add the parent to this page and within 2 seconds publish this page

The permalink will be "pay-go" even if initially it was pay-as-you-go. If the parent page title is made from few words, it's permalink will be broken as well.

For example, if you have a page About Us and underneath there is a page Our mission and vision, after these steps you will get something like "us/mission-vision" instead of "about-us/our-mission-and-vision"

Tested on
Multiple Wordpress 3.8 vanilla installations, no plugins whatsoever

Change History (6)

#1 @kutija
7 years ago

  • Keywords needs-patch added
  • Severity changed from normal to critical

#2 @bcworkz
7 years ago

  • Keywords 2nd-opinion added

Unable to replicate. May have to do with browser's javascript execution speed and not WordPress?

#3 @kutija
7 years ago

I've tested in Chrome 31.0.1650.63 and Firefox 26.0, both having the same issue.

#4 @jeremyfelt
7 years ago

  • Severity changed from critical to normal

I can't reproduce this in 3.8.1 using the steps provided with OSX 10.9 with Chrome 32.0.1700.77, Safari 7.0.1, or Firefox 26.0.

#5 @jbkkd
7 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

Also can't reproduce on 3.8.1 and 3.9 alpha with Windows 8 and Chrome 31.0.1650.63.

#6 @ocean90
7 years ago

  • Keywords needs-patch 2nd-opinion removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.