WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#26883 closed defect (bug) (invalid)

Add Media: Uploaded image title not populated

Reported by: squelch Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.5
Component: Media Keywords:
Focuses: Cc:

Description

Possibly related to #22672...?

In a vanilla install of WP3.8 (no plugins, TwentyFourteen theme), create a new page. Click "Add Media" and upload a new image. Set the title, alt, caption and description and insert the image into the page. Edit the image and the title is empty. Alternatively check the source in the text view and there is no title attribute. If you set a title in "Edit Image" then the new title will be honoured. The issue only exists when inserting an image from the "Add Media" box.

Change History (5)

#1 @helen
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed
  • Version changed from 3.8 to 3.5

This is deliberate as of 3.5 for better accessibility: #18984.

#2 @squelch
7 years ago

Thanks. While I can understand the reasons for the change, surely the names of the fields should also have been updated in Add Media to make it clear that "Title" is not the title attribute any more? When you group "Title", "Caption", "Alt Text", and "Description" into one place it creates an implied relationship between those fields and so anyone who's aware of the title and alt attribute is going to assume both are going to be inserted as attributes.

More importantly I'd argue that a typical user would expect "Title" in "Add Media" and "Title" in "Edit Media" to be one and the same. When I add a contact in my address book and it says "First Name", I would expect that to be the same as "First Name" when I come to edit the contact.

I can appreciate the reasons behind this and how it came about, I just think it's incredibly unintuitive.

At the very least I'd have thought a sensible change would be to rename "Title" in the "Add Media" box to differentiate it from the "Title" in the edit media box, even if you just changed it to "Media Title" then at least when I explain it to a customer I can point out that one field is called "Title" and one is called "Media Title" and that they are therefore different things.

In fact in the Media Library that field is named "File". Maybe that would work?

#3 @squelch
7 years ago

  • Resolution wontfix deleted
  • Status changed from closed to reopened

#4 @helen
7 years ago

  • Resolution set to invalid
  • Status changed from reopened to closed

That edit image dialog with advanced options does not exist in trunk with TinyMCE 4. It will come back, but in a different form. Perhaps at that point we can label it "title attribute".

As far as the "title" field goes, see #26270. I would argue that the average user does not know what title and alt attributes are, much less why use one or the other. The bug described in this ticket is not a bug.

#5 @SergeyBiryukov
7 years ago

#27197 was marked as a duplicate.

Note: See TracTickets for help on using tickets.