WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#27254 closed defect (bug) (duplicate)

add_theme_support from theme's should not be eclusionary

Reported by: webdevmattcrom Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Post Thumbnails Keywords:
Focuses: Cc:

Description

If a theme defines an array for defining thumbnail support, like so: add_theme_support('post-thumbnails', 'posts'), then plugins cannot override it, meaning any plugin that creates a custom post type and wants it to utilize a featured image cannot do that with add_theme_support. A workaround has been posted here: http://wordpress.stackexchange.com/questions/23839/using-add-theme-support-inside-a-plugin

But there should be the ability to simply add more thumbnail support in a standard fashion.

Change History (1)

#1 @SergeyBiryukov
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22080.

Note: See TracTickets for help on using tickets.