WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#27604 closed defect (bug) (wontfix)

MyISAM or InnoDB, why new plugins creates new tables as default MySQL option?

Reported by: AndyMalaga Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.8.1
Component: Database Keywords:
Focuses: Cc:

Description

WordPress 3.8.1 (last version) uses MyISAM table types, but if you install a new plugin using MySQL 5.5, by default table type is InnoDB, and new tables are created as InnoDB instead of MyISAM.

Finally you habe some tables as InnoDB and others as MyISAM becouse WordPress does create new tables as default type leaving this point to the luck, why? it's a but o is there any reason?

Thanks!

Change History (2)

#1 @pento
4 years ago

Thanks for the bug report!

WordPress doesn't specify an database engine, as we don't want to override the DBA's default-storage-engine setting, or assume that an engine exists when it may've been disabled.

Have you run into any specific errors caused by this?

#2 @pento
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

We don't plan on overriding MySQL's default-storage-engine option to fix this.

Note: See TracTickets for help on using tickets.