WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 2 years ago

#27645 closed defect (bug) (wontfix)

MediaElement.js player & playlist not keyboard accessible

Reported by: joedolson Owned by: wonderboymusic
Milestone: Priority: normal
Severity: normal Version: 3.6
Component: Media Keywords:
Focuses: accessibility Cc:
PR Number:

Description

The controls for MediaElementJS have an option to be always visible. When they are always visible, they are keyboard accessible, allowing keyboard-dependent users to play/pause, adjust volume, and go fullscreen in the video player.

When it is not always visible, there is no means to make it focusable using the keyboard.

This patch changes the setting to make the controls always visible.

Attachments (1)

27645.patch (1.1 KB) - added by joedolson 6 years ago.
Add default keyboard support to MediaElementJS player

Download all attachments as: .zip

Change History (14)

@joedolson
6 years ago

Add default keyboard support to MediaElementJS player

#1 @joedolson
6 years ago

  • Keywords has-patch added

#2 @samuelsidler
6 years ago

  • Milestone changed from Awaiting Review to 3.9

Moving to 3.9 for consideration.

#3 @nacin
6 years ago

  • Version changed from trunk to 3.6

I'd rather not always show controls. It's a significantly degraded experience. Seems to me like the real issue here is ME.js being unable to receive tabbing actions and then show the controls. This is new as of 3.6, not otherwise a regression.

#4 @nacin
6 years ago

  • Owner set to wonderboymusic
  • Status changed from new to assigned

Assigning to wonderboymusic to take a look.

#5 @jorbin
6 years ago

I have to agree with Nacin. This is something that should be fixed upstream. It is a degraded experience to always show the controls. We also would be changing the way existing videos are displayed, which is something that I can imagine many users wouldn't be happy with.

It does highlight that when we adopt front end libraries, we should make sure to consider if the accessibility standards they hold themselves to are the same ones that we hold for ourselves.

#6 @wonderboymusic
6 years ago

  • Milestone changed from 3.9 to Future Release

Will speak to the MEjs people about this

#7 @joedolson
6 years ago

That would be great. If the hidden controls could simply take :focus and become visible that would easily be the best solution.

#9 @afercia
4 years ago

Looks like the controls are now focusable and actionable with Spacebar/arrow keys. Would greatly appreciate someone to confirm this and maybe close this ticket. :)

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


3 years ago

#11 @rianrietveld
3 years ago

Checked this in Safari, Chrome and FireFox on Mac. The controls become visible on focus and then the controls can be used with the keyboard.

#12 @afercia
2 years ago

  • Milestone Future Release deleted

Controls are now focusable. Also, the MediaElementJS update planned in #39686 will bring in further interaction and accessibility improvements. Closing in favour of #39686.

#13 @afercia
2 years ago

  • Resolution set to wontfix
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.