WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 3 years ago

#27774 closed defect (bug) (invalid)

Customizer: Incorrect image scaling under image picker

Reported by: mauryaratan Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.4
Component: Customize Keywords: has-patch
Focuses: ui Cc:

Description

Currently under Theme Customizer when an image is selected under via image picker resizes incorrectly.

https://i.cloudup.com/91oxLnijtm.jpg

Apparently adding the following fixes the issue:

.accordion-section .customize-control-image .preview-thumbnail img {
  width: auto;
  height: auto;
}

Attachments (1)

27774.diff (437 bytes) - added by mauryaratan 4 years ago.
Sets the image widget/height to auto

Download all attachments as: .zip

Change History (10)

@mauryaratan
4 years ago

Sets the image widget/height to auto

#1 @mauryaratan
4 years ago

  • Keywords has-patch added

#2 @SergeyBiryukov
4 years ago

  • Component changed from General to Appearance

#3 @nofearinc
4 years ago

The patch works for me and fixes the issue. Tested with different dimensions and sizes, no incorrect scaling is applied and the images don't overflow the area.

#4 follow-up: @jeremyfelt
4 years ago

  • Version changed from trunk to 3.4

The current setting of width: 100%; was introduced in [20920] to fix the width for thumbnails in IE8 as part of a general IE8/9 Theme Customizer compatibility ticket, #20582.

@nofearinc & @mauryaratan - what browsers are you using? I see the issue in Chrome 34 on OSX, and the patch does correct it. Not entirely sure what it may impact though.

#5 in reply to: ↑ 4 @mauryaratan
4 years ago

Replying to jeremyfelt:

The current setting of width: 100%; was introduced in [20920] to fix the width for thumbnails in IE8 as part of a general IE8/9 Theme Customizer compatibility ticket, #20582.

@nofearinc & @mauryaratan - what browsers are you using? I see the issue in Chrome 34 on OSX, and the patch does correct it. Not entirely sure what it may impact though.

I see. I just checked it across different browsers, seems issue is not there in Firefox but it’s there in Safari and Chrome on OSX.

Do anyone here have IE here to test the patch?

#6 @nofearinc
4 years ago

Chrome 33 on Fedora Linux - I can reproduce the bug there and the patch fixes it. Firefox works with and without the patch for me.

#7 @mauryaratan
4 years ago

I just tested it under IE9/IE10 on Windows 7. The bug doesn't seems to be there, and applying the patch above doesn't creates any issue either, however it fixes the issue with webkit/blink based browsers.

#8 @graphical_force
3 years ago

Works for me on Chrome, IE 11, and Firefox 31 on Windows 8.1 with trunk. Suggest we close.

#9 @ocean90
3 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Invalid since [30309].

Note: See TracTickets for help on using tickets.