WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#27807 closed defect (bug) (worksforme)

can't paste into post/page editor

Reported by: nutsandboltsmedia Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9
Component: Editor Keywords:
Focuses: Cc:

Description

I'm using the latest development build and can't copy text from elsewhere to paste into the editor (this is happening with both the Visual and Text editor screens). On the Visual side, the editor simply doesn't respond, whether I use Command+V or right-click and choose Paste. On the Text side, the text pastes in, but when I save, it inserts   instead.

This is happening with Twenty Ten and no plugins active, as well as with any other theme I've tried (with and without plugins). I'm using Chrome for Mac (Mavericks).

This is also the first time I've submitted a bug report so please be gentle. :)

Change History (13)

#1 @nutsandboltsmedia
6 years ago

Just noticed the following error coming from /wp-includes/js/tinymce/plugins/wpview/plugin.min.js:

Uncaught TypeError: Object #<Object> has no method 'unbind' 

#2 @jeremyfelt
6 years ago

  • Keywords reporter-feedback added

Hi @nutsandboltsmedia, thanks for the report. I am not able to reproduce the issue on the latest development version - either in src or build. From that error message, it sounds like an issue with a plugin. Does this issue exist with Twenty Fourteen enabled and all plugins disabled?

#3 in reply to: ↑ description @jeremyfelt
6 years ago

Replying to nutsandboltsmedia:

This is happening with Twenty Ten and no plugins active, as well as with any other theme I've tried (with and without plugins). I'm using Chrome for Mac (Mavericks).

I missed this the first time. Tested with Twenty Ten as well, not able to reproduce.

#4 @nacin
6 years ago

Could you set this in wp-config? define( 'SCRIPT_DEBUG', true ); This would then allow us to get at a line number. It's likely going to be line 165.

If it works with SCRIPT_DEBUG on, then it's most likely that wp-includes/js/mce-view.min.js needs to be updated. If it points to line 165, I'd still probably blame it on wp-includes/js/mce-view.js (and mce-view.min.js) needing to be updated, though there could possibly be some other issue.

Are there no errors in the console?

#5 @nutsandboltsmedia
6 years ago

I've uploaded a screencast of what I'm seeing. Hopefully it will help (and I'm off to change wp-config now, @nacin).

Here's the screencast link: http://mbx.cm/t/mWFCy

#6 @nutsandboltsmedia
6 years ago

Still not working with SCRIPT_DEBUG on, but I do see the following:

Uncaught TypeError: Object #<Object> has no method 'unbind'

coming from /wp-includes/js/tinymce/plugins/wpview/plugin.js:165

#7 @szepe.viktor
6 years ago

Good morning Andrea!

Try a portable and blank browser when dealing with js errors!
http://sourceforge.net/projects/osxportableapps/files/Chromium/

I suspect your browser extensions in TinyMCE (Visual) editor.

Last edited 6 years ago by szepe.viktor (previous) (diff)

#8 @uriy84
6 years ago

Hi. I was able to replicate the same issue in build. I just updated to the latest version in src and it's working fine for me, the error message in console is gone.

#11 @nutsandboltsmedia
6 years ago

  • Keywords reporter-feedback removed
  • Resolution set to worksforme
  • Status changed from new to closed

This is now resolved for me as of the latest update.

#12 @nacin
6 years ago

  • Milestone Awaiting Review deleted

This ticket was mentioned in IRC in #wordpress-dev by nacin. View the logs.


6 years ago

Note: See TracTickets for help on using tickets.