WordPress.org

Make WordPress Core

Opened 8 years ago

Closed 8 years ago

Last modified 4 years ago

#2807 closed defect (bug) (fixed)

can't delete comments

Reported by: tenpura Owned by:
Milestone: Priority: normal
Severity: normal Version: 2.0.3
Component: Administration Keywords: bg has-patch comments
Focuses: Cc:

Description

Comments can't be deleted from Manage > Comments > Delete Comment link.

Attachments (2)

2807.diff (1.4 KB) - added by tenpura 8 years ago.
patch for /branches/2.0/
2807_trunk.diff (3.5 KB) - added by tenpura 8 years ago.
patch for /trunk/

Download all attachments as: .zip

Change History (13)

tenpura8 years ago

patch for /branches/2.0/

comment:1 tenpura8 years ago

  • Keywords bg|has-patch added

tenpura8 years ago

patch for /trunk/

comment:2 tenpura8 years ago

  • Milestone changed from 2.0.4 to 2.1

2807_trunk.diff

I replaced some $post->ID with $comment->comment_post_ID. I also deleted an unnecessary \.

comment:3 tenpura8 years ago

  • Milestone changed from 2.1 to 2.0.4
  • Version changed from 2.0.2 to 2.0.3

Milestone: 2.0.4 and 2.1

comment:4 spencerp8 years ago

After uploading the "latest" files from the branch/2.0 for 2.0.4-alpha, on my main blog, it seems to be working just fine for me. I had tried deleting a comment via Manage => Comments => Delete, and it deletes it, and I have also clicked on the Edit Comment button and deleted it that way as well. Seems go to go in my book. :)

comment:5 tenpura8 years ago

Please try again with JavaScript off, spencerp.

In addition, this Ajax thing seems incompatible with Opera.

comment:6 spencerp8 years ago

Oh, ok..I have now tried it with the javascript off, and it will delete it while "Editing" the comment, but when doing it this route: Manage => Comments => Delete
,it will show a message: "Oops, no post with this ID. Go back!"

I see what you're talking about tenpura. =) Hmm, let me see once..

comment:7 JeremyVisser8 years ago

  • Keywords bg has-patch comments added; bg|has-patch removed

Confirmed - this patch fixes the problem for me. Tested on latest WP trunk (rev. 3943).

comment:8 ryan8 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [3944]) Delete comment fix from tenpura. fixes #2807

comment:9 ryan8 years ago

(In [3945]) Delete comment fix from tenpura. fixes #2807

comment:10 anonymous7 years ago

  • Milestone 2.0.4 deleted

Milestone 2.0.4 deleted

comment:12 filosofo4 years ago

  • Milestone Unassigned deleted
Note: See TracTickets for help on using tickets.