WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#28181 closed defect (bug) (duplicate)

Auto-upgrades moved me from 3.9 to 4.0-alpha

Reported by: leewillis77 Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Upgrade/Install Keywords:
Focuses: Cc:

Description

At 20.30 (BST) I received an auto-upgrade email from my site (Which has standard settings, e.g. minor updates only. The email read:

"Your site at http://xxxxxxxx has been updated automatically to WordPress 3.9.1. No further action is needed on your part. For more on version 3.9.1, see the About WordPress screen: http://xxxxxxxxxx/wp-admin/about.php If you experience any issues or need support, the volunteers in the WordPress.org support forums may be able to help. https://wordpress.org/support/ You also have some plugins or themes with updates available. Update them now: http://xxxxxxxx/wp-admin/ The WordPress Team

However, on the updates page within WordPress I'm currently receiving the message:

"BETA TESTERS: This site is set up to install updates of future beta versions automatically."

This site shouldn't be set up to run beta releases. The "At a glance" panel in WordPress admin reports the version number as "WordPress 4.0-alpha".

This should not be the case.

wp-includes/version.php indeed reports that 4.0-alpha has been installed.

$wp_version = '4.0-alpha';
$wp_db_version = 27916;
$tinymce_version = '4021-20140423';
$required_php_version = '5.2.4';
$required_mysql_version = '5.0';
$wp_local_package = 'en_GB';

For reference I was running the en_GB version.

Change History (4)

#1 @ocean90
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28179.

#2 follow-up: @leewillis77
4 years ago

Thanks for the swift reply. While I get the fact that this is a translation issue - is it also something that the core upgrade process should catch itself?

#4 in reply to: ↑ 2 @nacin
4 years ago

Replying to leewillis77:

Thanks for the swift reply. While I get the fact that this is a translation issue - is it also something that the core upgrade process should catch itself?

Core can't catch it, but WordPress.org can/should/will. We're going to be rewriting mostly everything as part of some 4.0 work, so this won't be able to happen again.

Note: See TracTickets for help on using tickets.