WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

#28438 closed enhancement (duplicate)

thinking about resizing images

Reported by: alexufo Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Media Keywords:
Focuses: Cc:

Description

As we know wp can resize images only on upload. I think this is big problem for websites in future. This is not flex way. I know about plugins re-resizing all old images with new settings, but this is so strange...
the best organization resizing images what i know, i see in opencart.
It resized images on the fly with htaccess and saved it to cache.
You can better understand me by reading this article
http://www.myrant.net/2011/03/07/resize-images-on-the-fly-without-messing-with-image-urls/

I think this is the best method for work with image resizing in any cms.
We resized images only if not exist in cache.
I think we should save images in wp-upload folder only for original images. All images with name like 100x200-aaa.jpg in wp-upload are temporary by default (because web design are not constant) and should be saved in cache folder.

I may be wrong. Sorry. May be current image organization in wp historical important

Change History (1)

#1 @helen
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #15311.

Note: See TracTickets for help on using tickets.