WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

#28565 closed defect (bug) (duplicate)

Hotlink defaults to local site prefix after first such use

Reported by: Jim Bennett Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Editor Keywords:
Focuses: Cc:

Description

I frequently link to other sites. I generally use 'open in a new window' option. I rarely link to content in my own site. Today I did so, and then realized that an earlier, external page link, went to the wrong place. So, I un-linked it, and re-linked it using (as always) cut&paste from the other Firefox window.
This one link failed after the post was updated: the URL when editing in WordPress did not show this, but in reality, my website was prefixed to (in this case Wikipedial) the page I'd linked to.
I retried several times, then exited WordPress administrator entirely, re-entered, and fixed the hotlink.
So, I'm pretty sure that the WordPress editor 'remembers' (incorrectly) that you want to link locally, even when you say you don't.
Again, re-entering WP admin cold, I could make the link correctly.
I am using 3.9.1 but 2011 theme, not latest update.

Change History (5)

#1 follow-up: @SergeyBiryukov
6 years ago

  • Component changed from General to Editor

my website was prefixed to (in this case Wikipedial) the page I'd linked to.

This happens if you remove the default http:// prefix from the link, which makes the link relative.

Sounds like a duplicate of #18149.

#2 in reply to: ↑ 1 @Jim Bennett
6 years ago

Replying to SergeyBiryukov:

my website was prefixed to (in this case Wikipedial) the page I'd linked to.

This happens if you remove the default http:// prefix from the link, which makes the link relative.

Sounds like a duplicate of #18149.

I always cut(from another window) and paste over the 'http://' prefix, and it always works, EXCEPT if I've done a local link before, in the same WP admin session. Then it does not work, as I described.

#3 @SergeyBiryukov
6 years ago

FWIW, Chrome sometimes omits the http:// prefix when I copy a full URL from the address bar. I could not reproduce it on purpose though.

#4 @johnbillion
6 years ago

Sounds like we need a JavaScript implementation of esc_url_raw() to use when inserting links.

#5 @iseulde
5 years ago

  • Focuses administration removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 3.9.1 deleted

Duplicate of #18149.

Note: See TracTickets for help on using tickets.