WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#28813 closed defect (bug) (duplicate)

wp_editor() does not work when textarea name uses brackets

Reported by: veganist Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Editor Keywords:
Focuses: Cc:

Description

This is related to #27601.

Since 3.9 it's not possible anymore to use wp_editor on a textarea with brackets in the name.

<textarea name="foo[bar]"></textarea>

However, using brackets in the name is perfectly valid afaik, and helps to add the texteditor's content to a set of variables, sent with a form.

So, simply telling the user that this does not work does not seem to be a valid fix to me.

Am i missing something? Is there a known workaround which does not require modifying the whole database of already saved meta data?

Change History (2)

#2 @SergeyBiryukov
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #28079.

Note: See TracTickets for help on using tickets.