WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#28848 closed defect (bug) (duplicate)

Wrong error message when a customer register email address to one including an ampersand

Reported by: dots Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Users Keywords:
Focuses: Cc:

Description

Wrong error message when a customer register email address to one including an ampersand.

Attachments (1)

error_message.png (33.4 KB) - added by dots 7 years ago.
error_message

Download all attachments as: .zip

Change History (4)

@dots
7 years ago

error_message

#1 @dd32
7 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Hi dots,

I apologise for the delay in getting a response here!
This appears to be being produced by a plugin, as WordPress allows emails containing & (which is valid).

Since I can't reproduce a registration error with a email with &, I'm going to close this and suggest you try the Support Forums if you're still experiencing a problem.

#2 @valendesigns
7 years ago

This is not caused by a plugin, it's actually an issue with wp_filter_kses on pre_user_email and this ticket is a duplicate of #21537. I've already submitted a patch that fixes it, but I'm still waiting on a response.

#3 @SergeyBiryukov
7 years ago

  • Resolution changed from worksforme to duplicate

Duplicate of #21537.

Note: See TracTickets for help on using tickets.