WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#28958 closed defect (bug) (duplicate)

Icons disappear with future edits to post or page.

Reported by: miglehu Owned by:
Milestone: Priority: normal
Severity: normal Version: 3.9.1
Component: Editor Keywords:
Focuses: Cc:

Description

In a page or post you can use the html editor to add icons using the <span class=""></span> method.

See example (http://css-tricks.com/html-for-icon-font-usage/)

It works as expected the first time you publish it. However, when you edit that page or post later, all icons and icon code disappears.

To Summarize
When you return to editing a page or post containing icons, the icons and the code that generated them are gone. In other words, <span class=""></span> is missing when you return to edit a previously published post or page. This can be quite troublesome when such icons are used on a page or post that is updated frequently.

Change History (1)

#1 @SergeyBiryukov
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #26986 and #28940.

Note: See TracTickets for help on using tickets.