WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 19 months ago

Last modified 7 months ago

#29274 closed defect (bug) (fixed)

Plugin details show username instead of display name

Reported by: kidsguide Owned by: dd32
Milestone: 5.1 Priority: normal
Severity: critical Version: 4.0
Component: Plugins Keywords: needs-patch 2nd-opinion
Focuses: Cc:

Description

In WordPress 4.0 beta4 when view the details for a plugin, the contributors names display there original name instead of display name.

Attachments (1)

29274.diff (1.9 KB) - added by nacin 5 years ago.

Download all attachments as: .zip

Change History (36)

#1 follow-up: @SergeyBiryukov
5 years ago

  • Version set to trunk

It displays WordPress.org usernames from the plugin's readme.txt file.

#2 in reply to: ↑ 1 @kidsguide
5 years ago

Replying to SergeyBiryukov:

It displays WordPress.org usernames from the plugin's readme.txt file.

But if you don't use your original name then it doesn't have a link to your profile. You may not be like me but I have changed my WordPress display name from its original name.

#3 follow-up: @SergeyBiryukov
5 years ago

The plugin directory displays actual names, so I guess it would indeed make sense to be consistent.

Looks like it requires an API change to return display names along with usernames though.

#4 in reply to: ↑ 3 @kidsguide
5 years ago

Have you looked at it yourself?

#5 follow-up: @SergeyBiryukov
5 years ago

I did, the API currently only returns WP.org usernames and profile links.

#6 in reply to: ↑ 5 @kidsguide
5 years ago

Do you think this is an error or is it meant to be there?

#7 follow-up: @tellyworth
5 years ago

  • Milestone changed from Awaiting Review to Future Release

Some discussion here: https://core.trac.wordpress.org/ticket/27440#comment:36

Contributors are returned by the API as an array of (username => profile_url) pairs. The username string is used to generate the avatar (via wp.org's grav-redirect.php endpoint). That's not great, but it does avoid revealing contributors emails.

Fixing it would require a new structure that allows for at least 3 items per contributor: gravatar identifier; display name; and url. That's not going to happen for 4.0 but it's worth revisiting in 4.1, since it'd also allow the possibility of eliminating those grav-redirect hops.

#8 in reply to: ↑ 7 ; follow-up: @ocean90
5 years ago

Replying to tellyworth:

That's not going to happen for 4.0 but it's worth revisiting in 4.1, since it'd also allow the possibility of eliminating those grav-redirect hops.

That's bad, why can't it happen now?

#9 in reply to: ↑ 8 @kidsguide
5 years ago

It would be nice if it is added in 4.0.

Last edited 5 years ago by kidsguide (previous) (diff)

#10 @kidsguide
5 years ago

  • Focuses administration added

Here is an image of the problem.

http://www.redeemerdanceacademy.ca/wp-content/uploads/2014/09/Ticket-2.png

#11 @kidsguide
5 years ago

  • Focuses administration removed

#12 @kidsguide
5 years ago

Last edited 4 years ago by kidsguide (previous) (diff)

#13 @nacin
5 years ago

  • Milestone changed from Future Release to 4.0.1

I think this is something we might fix in 4.0.1.

I knew grav-redirect.php was in core at one point, but I didn't realize we shipped with it. Those loops are not great for performance (both front-end performance and also it's extra work on WordPress.org).

We should be able to adjust the API to also ship display name and hash. For 4.0.1 we can just build our own gravatar.com URL without using get_avatar(), as get_avatar() doesn't support receiving a hash currently, and it's pluggable so changing it guarantees nothing. (We do this on the credits page, too.)

This ticket was mentioned in IRC in #wordpress-dev by MarkJaquith. View the logs.


5 years ago

@nacin
5 years ago

#15 @nacin
5 years ago

  • Keywords has-patch commit added

#16 follow-up: @ocean90
5 years ago

With 29274.diff the display name is still not displayed, by design?

This ticket was mentioned in IRC in #wordpress-dev by nacin1. View the logs.


5 years ago

#18 in reply to: ↑ 16 @nacin
5 years ago

Replying to ocean90:

With 29274.diff the display name is still not displayed, by design?

For the moment, yes. We can make this better if we wanted to.

#19 @nacin
5 years ago

  • Keywords needs-patch added; has-patch commit removed
  • Milestone changed from 4.0.1 to 4.1

We need to add display name and such to the API.

#20 @kidsguide
5 years ago

  • Summary changed from Displays Original Name in Plugin Details Instead of Display Name to Displays default display name in plugin details instead of display name

#21 @johnbillion
5 years ago

  • Keywords needs-patch removed
  • Milestone changed from 4.1 to WordPress.org

#22 @SergeyBiryukov
5 years ago

  • Summary changed from Displays default display name in plugin details instead of display name to Plugin details show username instead of display name

#23 @kidsguide
5 years ago

Why is this a WordPress.org thing?

#24 @johnbillion
5 years ago

Display name needs to be added to the API response.

#25 @kidsguide
5 years ago

Gotcha

Last edited 5 years ago by kidsguide (previous) (diff)

This ticket was mentioned in Slack in #meta by ocean90. View the logs.


3 years ago

#27 @Otto42
3 years ago

The API change needed to support 29274.diff would not be backward compatible, unless we bumped the version number of the API request as well.

An alternative approach would be to use a new field other than "contributors" to hold the new information.

#28 @dd32
3 years ago

  • Milestone changed from WordPress.org to Future Release

The API change required for this patch had already been made.
The format of the contributors key varies depending on if the contributors flag is present in the fields or not.

I've just added the display_name field to the response as well, as evidenced by https://api.wordpress.org/plugins/info/1.0/akismet.json?fields=contributors

As all the required API changes have been made, I'm shifting this back to Core.

#29 @dd32
19 months ago

  • Keywords needs-patch added
  • Milestone changed from Future Release to 5.0
  • Owner set to dd32
  • Status changed from new to accepted

#30 @dd32
19 months ago

#43165 was marked as a duplicate.

#31 @dd32
19 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 42631:

Plugins: Use api.wordpress.org/plugins/info/1.2/ for querying plugins & plugin information.

See #43192.
Fixes #29274.

#32 @SergeyBiryukov
19 months ago

In 42686:

Plugins: Use correct variable name in install_plugin_information().

Props afragen.
Fixes #43282. See #43192, #29274.

#33 @Luciano Croce
14 months ago

  • Keywords 2nd-opinion added
  • Severity changed from normal to critical

IMHO "display name" instead of the "original name" open the possibility of "puppet socketing" on case of people with multiple account.

Registering one acount is a delicated pratice, a serious problem for the idenfication of the real status of identity online.

For example:

Original Name - profiles.wordpress.org/spammer -> Display Name - Mario Bross
Original Name - profiles.wordpress.org/spamm3r -> Display Name - Mario Bross
Original Name - profiles.wordpress.org/sp4mmer -> Display Name - Mario Bross
Original Name - profiles.wordpress.org/sp4mm3r -> Display Name - Mario Bross

This is one example with user with 4 accounts and 3 fake or puppet.

This pratice is absolutely rejected and not permitted from the plugin directory guidelines for example!

#34 @johnbillion
11 months ago

  • Milestone changed from 5.0 to 5.1

#35 @JoshuaWold
7 months ago

Howdy! Would it be possible to see a quick screenshot of the last changes in the interface? Thanks!

Note: See TracTickets for help on using tickets.