WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#29422 closed defect (bug) (fixed)

Can't get to network admin with keyboard

Reported by: Cheffheid Owned by: wonderboymusic
Milestone: 4.2 Priority: normal
Severity: normal Version: 3.9.2
Component: Toolbar Keywords: has-patch
Focuses: accessibility, multisite Cc:

Description

I'm using a multisite install and so have "My Sites" in my toolbar.

When I'm browsing the admin section with my keyboard, I can expand the "My Sites" menu with Enter. However, when I then select either "Network Admin" or any of my sites and hit Enter again the submenu closes and nothing happens.

Funnily enough: When I then hover over "My Sites" with my mouse, the "Network Admin" submenu does appear right away. Unfortunately, this does not seem to be the case when I try to tab back into the "My Sites" submenu.

Occurs in Chrome 36 and Firefox 31. Appears on IE11 as well.

Tested, and reproducable, in 3.9.2 and trunk.

Attachments (2)

29422.patch (816 bytes) - added by Cheffheid 6 years ago.
This seems to fix it.
29422.2.patch (858 bytes) - added by Cheffheid 6 years ago.

Download all attachments as: .zip

Change History (12)

#1 @SergeyBiryukov
6 years ago

  • Focuses multisite added

@Cheffheid
6 years ago

This seems to fix it.

#2 @SergeyBiryukov
6 years ago

  • Keywords has-patch added

#3 @johnbillion
6 years ago

  • Keywords needs-testing added
  • Milestone changed from Awaiting Review to Future Release

#4 follow-up: @jesin
6 years ago

@Cheffheid: Thanks for the patch. When creating patches do it from the root directory of WordPress (the place where files like wp-config.php reside).

Tested 29422.patch and found the following bug:

https://i.imgur.com/vzPqiuP.png

Opening a submenu doesn't close the previously opened ones.

Another bug exists in the core (not related to this patch):

https://i.imgur.com/HK7AXg7.png

If an admin bar menu is opened using keyboard shortcuts it doesn't close itself when the focus goes to the admin menu.

#5 in reply to: ↑ 4 @Cheffheid
6 years ago

Will do, thanks! The guide to creating patches with TortoiseSVN wasn't very clear about that, will keep it in mind.

Noticed the admin side menu works slightly different from the toolbar. That is to say, the side menu seems to automatically open the submenus when tabbing through. Maybe keep it consistent and have the admin toolbar work that way too (or vice versa)?

@Cheffheid
6 years ago

#6 @Cheffheid
6 years ago

Added a new one.

Turns out I was overcomplicating things a little. wrap selector wasn't right, fixing that helped but then the toggling stopped working. Probably because it would remove and then add the hover state in one go. Resulting in the submenu staying open when hitting enter repeatedly on a menu item like "Network Admin".

This patch will also make sure if it should toggle the hover class after removing it or not. If that makes sense :).

Last edited 6 years ago by Cheffheid (previous) (diff)

#7 @wonderboymusic
6 years ago

  • Owner set to wonderboymusic
  • Status changed from new to reviewing

#8 @jeremyfelt
6 years ago

  • Keywords needs-testing removed
  • Milestone changed from Future Release to 4.2

29422.2.patch is doing the trick for me.

#9 @SergeyBiryukov
6 years ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 31111:

Toolbar: Make network admin accessible via keyboard.

props Cheffheid.
fixes #29422.

This ticket was mentioned in Slack in #accessibility by cheffheid. View the logs.


5 years ago

Note: See TracTickets for help on using tickets.