WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 6 years ago

#29693 closed defect (bug) (invalid)

Search in admin + two other issues

Reported by: farsad Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Administration Keywords: reporter-feedback close
Focuses: administration, template Cc:

Description

Hi
in admin panel => posts => show all posts

  • Search in posts returns nothing
  • Changing pages using type number and enter returns nothing

in main website

  • Search function doesn't return some posts for example a post with this address :

http://www.chibokhorim.ir/%D8%AE%D9%85%DB%8C%D8%B1-%D9%BE%DB%8C%D8%AA%D8%B2%D8%A7/
directly search by search function doesn't return that post
look below
http://www.chibokhorim.ir/?s=%D8%AE%D9%85%DB%8C%D8%B1+%D9%BE%DB%8C%D8%AA%D8%B2%D8%A7

the theme loop is :
<?php if(have_posts()) {
while(have_posts()) { the_post();
.
.
.

Please answer as soon as it possible.

Attachments (1)

29693.search-input.png (3.6 KB) - added by SergeyBiryukov 7 years ago.

Download all attachments as: .zip

Change History (7)

#1 @SergeyBiryukov
7 years ago

  • Keywords reporter-feedback added

Could not reproduce the search issues on a clean install:

  1. Created a post with that title.
  2. Search for that title in the admin works as expected.
  3. Search for that title on the front-end works as expected too.

Does it still happen with all plugins disabled and a default theme (Twenty Fourteen or Twenty Thirteen) activated?

#2 @farsad
7 years ago

Ok i tried to create a post with that title and it worked but what about that post? and also the direct page number in admin panel?

#3 @SergeyBiryukov
7 years ago

Do you mean the input in 29693.search-input.png? If I change the number and press Enter, it works as expected for me as well.

I'd suggest trying the support forums for troubleshooting: https://wordpress.org/support/.

#4 @farsad
7 years ago

find the issue
yes i mean that but read this
after enter this will go on address
http://www.chibokhorim.ir/wp-admin/edit.php?s&post_status=all&post_type=post&action=-1&m=0&cat=0&paged=2&mode=list&action2=-1

I don't know what is the "m" parameter but i know after removing that parameter it worked.

#5 @chriscct7
6 years ago

  • Keywords close added

Unable to reproduce this as well

#6 @johnbillion
6 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.