WordPress.org

Make WordPress Core

Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#29793 closed defect (bug) (invalid)

Author Archives not Generated for users who create Gravatar Profile AFTER being added as author

Reported by: hopetommola Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.0
Component: Users Keywords: reporter-feedback
Focuses: multisite Cc:

Description

WordPress 4.0 multisite. New student bloggers are added to the Admissions blog annually. Some authors didn't have Author Archives, but rather a "This is somewhat embarrassing, isn’t it?" page. I scrutinized the users who *did* have archives and it appeared that they had gravatar profiles setup, but the new users did not.

So we asked the new authors to setup their gravatar profiles using their college email address (same as used for their author accounts) thinking this would resolve the issue. It did not.

So we tested by adding a user (me) who was not already an author, but already had a gravatar account. After adding me as an author and creating a post, I immediately had an Author Archive page.

Short story - Author Archives are only created when the author has a gravatar profile *prior to* being added as a user.

PLEASE tell me I am missing something simple of foolish ... because this seems too odd to be an actual bug.

Much thanks
CT

Change History (10)

#1 @SergeyBiryukov
7 years ago

  • Focuses performance removed
  • Keywords reporter-feedback added

Author archives are not related to Gravatar profiles in any way, something else must be going on.

  1. Do the new users actually have published posts?
  2. Does the issue still happen with all plugins disabled and a default theme (Twenty Fourteen or Twenty Thirteen) activated?

#2 @hopetommola
7 years ago

Adding a new author with an existing gravatar profile creates an author archive properly. Adding a new author who does *not* have a gravatar profile results in a missing author archive. Both author archives were tested after test posts were created and published.

All the users do have published posts. I have tried all combinations for the author archive url, including the ?author=# method and combination of usernames: first-last, firstlast, first.last with and without caps.

The current theme is a child of Twenty Eleven and always has been - no change.

I have not tested with all plugins deactivated (due to the impact on the rest of the network sites) but no new plugins have been added. Only core updates and updates to existing plugins. I may be able to test this on the development server, after some coworkers are available.

#3 @hopetommola
7 years ago

I am duplicating the current live site to the dev server and testing more extensively. Will update. Note that completely removing an existing author (with existing gravatar) with existing posts, reattributing those posts to a new author, deleting the original author as a user, re-adding and re-attributing the posts to the author did NOT solve the problem.

#4 @hopetommola
7 years ago

I have duplicated the site to a dev server. Deactivated all plugins, both network plugins and individual plugins. I changed the theme to 2014. The authors who didn't have author pages previously still do not have author pages

#5 @hopetommola
7 years ago

All of the Author pages which are missing default to /author/FirstLast/ while all the Author pages which work properly default to /author/first-last/ ... however, if I change the format, this doesn't fix the issue.

#6 @hopetommola
7 years ago

I edited the page template in 2014 to insert a list of authors:

<ul>
<?php wp_list_authors('exclude_admin=0&hide_empty=0'); ?>
</ul>

All of the Authors with missing Author Archives have "Firstname Lastname" in the URL. Caps and a space. Space renders as %20 and archive doesn't work.

All the Authors which work have the URL as "firstname-lastname".

All users were added through an LDAP connection using Simple LDAP Login https://wordpress.org/plugins/simple-ldap-login/, with a default role of subscriber. However, they're not elevated to Author until they're users in WP. And all details of their profiles look the same in WP admin.

Thoughts?

#7 @dd32
7 years ago

It sound like you've got invalid records in the wp_users table, possibly the user_nicename field is set incorrectly for these users.

user_nicename is a URL sanitized form of their username/login, usually this would be set to 'first-last', but if a plugin has set it to 'First Last' incorrectly then the archive won't work (We don't support Spaces in author url slugs)

#8 @dd32
7 years ago

All users were added through an LDAP connection using Simple LDAP Login https://wordpress.org/plugins/simple-ldap-login/

Definately sounds like the issue: https://wordpress.org/support/topic/automatic-user-creation

Fix the wp_users records and it should be fine, if that's indeed the cause, feel free to mark this ticket invalid.

#9 @hopetommola
7 years ago

  • Resolution set to invalid
  • Status changed from new to closed

I've confirmed that modifying the user_nicename directly in the database does in fact fix the issue. Thank you for the support in working through this. I have communicated the issue to the plugin developer.

#10 @DrewAPicture
7 years ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.