WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#30231 closed defect (bug) (duplicate)

Internal Plugin search will not find plugin names with a forward slash in them

Reported by: prophecy2040 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Plugins Keywords:
Focuses: Cc:

Description

Apologies if this was reported previously - I could not find anything relevant.

I am a plugin developer and one of my plugin names is called "Quick Page/Post Redirect Plugin". I have recently had some users tell me that they cannot find the plugin when using the 'Add New' plugin search feature inside WordPress. I checked this out and it does come up, BUT not when you use the actual full name (with the '/' - forward slash). If you take it out, it shows up.

So looking through the plugin development documentation, I cannot find anything where is says not to include a forward slash in the name of the plugin. So my conclusion is that this is a bug of some sort, as the search process is possibly converting the forward slash to an encoded character which will not match the title of the plugin - so it does not return a result.

To recreate, try searching "Quick Page/Post Redirect Plugin" and nothing will return. When you search "Quick PagePost Redirect Plugin" (without the /) the plugin will be listed.

The plugin was created a long time ago, and the name has not changed since inception. I tested in 3.8, 3.9 and 4.0 with the same results.

If this is not a bug, there needs to be more clear instruction on Plugin naming conventions, so that developers will know not to use certain characters in their naming so users can find the plugin correctly.

Don Fischer

Change History (3)

#1 @SergeyBiryukov
5 years ago

  • Focuses administration removed
  • Milestone changed from Awaiting Review to WordPress.org
  • Version trunk deleted

Reproduced with the search form in the plugin directory as well:

#2 @chriscct7
4 years ago

  • Milestone WordPress.org deleted
  • Resolution set to invalid
  • Status changed from new to closed

#3 @SergeyBiryukov
4 years ago

  • Resolution changed from invalid to duplicate
Note: See TracTickets for help on using tickets.