WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 5 years ago

#30974 closed feature request (duplicate)

Use a JSON file for theme and plugin details

Reported by: retlehs Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:
PR Number:

Description

Currently plugin details go in a PHP comment and theme details go in a CSS comment. The file header specification could be removed in favor of valid JSON.

I haven't thought about how this setup would work with mu-plugins.

Ref:

Change History (1)

#1 @ocean90
5 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #24152.

Note: See TracTickets for help on using tickets.