WordPress.org

Make WordPress Core

Opened 5 years ago

Last modified 5 months ago

#31293 new defect (bug)

Previously uploaded attachment affects page slug

Reported by: funorang Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.1
Component: Permalinks Keywords:
Focuses: Cc:
PR Number:

Description

I have page url: abc.com/products/novus-3 (novus page never create but it add -3 in url)

so i check directly where the page exist: abc.com/products/novus So basically i found the banner image i upload only showing in this url as ATTACHMENT ID, So i delete that header image and change my page url "NOVUS-3 to NOVUS" and after that i re-add image. Its fine.

But the question is when creating new page, for example Page title: New Page so url will be /new-page but before setting page title if we import image with the same name of page title, the Permalink url reserved that desired page url. So everytime first add Page title first then add image.

Hope you understand, sorry for my bad english.

Thanks

Change History (2)

#1 @SergeyBiryukov
5 years ago

  • Component changed from Administration to Permalinks
  • Summary changed from Attach image Permalink to Previously uploaded attachment affects page slug

#2 @seancjones
4 years ago

Welcome funorang. I'm sorry it's taken so long to respond to your issue. Are you running any plugins or have you been able to see this happen with a fresh installation as well? Typically an image link wouldn't interface with a page permalink.

Note: See TracTickets for help on using tickets.