Make WordPress Core

Opened 9 years ago

Closed 5 years ago

#31788 closed enhancement (fixed)

WordPress Lost Your Password form Error Message Inaccuracies

Reported by: mrtortai's profile mrtortai Owned by: pento's profile pento
Milestone: 5.1 Priority: normal
Severity: normal Version:
Component: Login and Registration Keywords: has-patch commit
Focuses: ui, accessibility Cc:

Description

The WordPress Lost Your Password form (/wp-login.php?action=lostpassword) accepts a username or an email address.

If you enter an incorrect email address, the following message will display: "ERROR: There is no user registered with that email address."

If you enter an incorrect username, the following message will display: "ERROR: Invalid username or e-mail."

This can produce confusing error messages. Additionally, using "e-mail" and "email" in the two error messages is not consistent.

For example, here are values entered and the resulting error message:

abcde -> ERROR: Invalid username or e-mail.
abcd@ -> ERROR: There is no user registered with that email address.

This small patch standardizes the message to:
"ERROR: There are no user accounts using that username or e-mail address. Please try again."

Additionally, wp-login.php had 8 messages using "e-mail" and 4 messages using "email" so they have been updated to "e-mail" (as that was the more common of the two).

Attachments (4)

31788.patch (2.2 KB) - added by mrtortai 9 years ago.
Patch for Ticket #31788
31788.diff (1.1 KB) - added by iamfriendly 9 years ago.
Refreshed the patch to just modify the strings to make them consistent and tidy up the surrounding code to WP coding standards
31788.2.diff (967 bytes) - added by TomHarrigan 6 years ago.
Patch refresh for #31788
31788.3.diff (966 bytes) - added by TomHarrigan 6 years ago.
Fix typo from last refresh, keep second string instance with 'invalidcombo' rather than mistakenly changing to 'invalid_email'

Download all attachments as: .zip

Change History (19)

@mrtortai
9 years ago

Patch for Ticket #31788

#1 @mrtortai
9 years ago

  • Keywords has-patch needs-testing added

#2 @MikeHansenMe
9 years ago

"email" is used more throughout core than "e-mail". I seem to remember a decision on it some time before. When trying to find it I could not. Maybe someone else can shed some light on that decision.

#3 @voldemortensen
9 years ago

According to #26156 AP has started accepting email as the correct spelling. The changes haven't been implemented yet though.

More in depth discussion: #14366 (which is now a duplicate of #26156, but has more discussion)

#4 @SergeyBiryukov
9 years ago

  • Component changed from General to Login and Registration

#5 @iseulde
9 years ago

  • Version trunk deleted

@iamfriendly
9 years ago

Refreshed the patch to just modify the strings to make them consistent and tidy up the surrounding code to WP coding standards

#6 @iamfriendly
9 years ago

Just a refresh of the patch to just include the improved strings as well as tidying up the surrounding code to WP Coding Standards. (The change from e-mail -> email occurred in a subsequent release to the initial patch)

#7 @afercia
6 years ago

  • Focuses ui accessibility added
  • Keywords needs-refresh added; needs-testing removed

Trying to help this ticket move on: this is also a WCAG requirement, as recently pointed out in #42985, as error messages after users input should always clearly describe what's wrong.

I see in the meantime WordPress has standardized on the term email without hyphen, so the patch would need a quick refresh. I'd also suggest to shorten a bit the message, maybe removing the Please try again. part?

@TomHarrigan
6 years ago

Patch refresh for #31788

This ticket was mentioned in Slack in #accessibility by tomharrigan. View the logs.


6 years ago

@TomHarrigan
6 years ago

Fix typo from last refresh, keep second string instance with 'invalidcombo' rather than mistakenly changing to 'invalid_email'

#9 @audrasjb
6 years ago

  • Keywords needs-refresh removed
  • Milestone changed from Awaiting Review to 5.0.1
  • Owner set to audrasjb
  • Status changed from new to assigned

Hi,
I tested the refreshed patch and it looks ok on my side, thanks.
Moving to the next minor milestone.

#10 @pento
6 years ago

  • Milestone changed from 5.0.1 to 5.0.2

#11 @pento
6 years ago

  • Milestone changed from 5.0.2 to 5.0.3

#12 @audrasjb
5 years ago

  • Keywords commit added

This ticket is triaged in milestone 5.0.3, the patch looks good, smaller enough for a minor release and self-contained. Adding commit keyword to see if it can land in 5.0.3.

#13 @desrosj
5 years ago

  • Milestone changed from 5.0.3 to 5.1

This looks good, but let's fix it in 5.1 as it falls outside of the 5.0.3 priorities.

#14 @pento
5 years ago

  • Owner changed from audrasjb to pento

#15 @pento
5 years ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 44489:

Login: Improve the error message when retrieving a lost password.

When an invalid username or email address is entered, the form now displays a better error message.

Props mrtortai, iamfriendly, TomHarrigan, afercia, pento.
Fixes #31788.

Note: See TracTickets for help on using tickets.