WordPress.org

Make WordPress Core

Opened 4 years ago

Closed 4 years ago

#32479 closed defect (bug) (duplicate)

HTTPS is forced when uploading images

Reported by: rupiee Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Administration Keywords: reporter-feedback
Focuses: administration Cc:

Description

Hi,

It seems that since 4.2.0, all pictures added via Media Uploader to the post are by default linked as HTTP_S_. This happens when the user is administering the website via HTTPS.

Before, you could administer the site via HTTPS but all the pictures were given HTTP schema by default - and that's preferred solution, because some blogs use Cloudflare's ECDSA certificates, and when user on Windows XP SP2 or older Android enters the site via HTTP (that has images linked via HTTPS), he or she won't be able to see the HTTPS linked image. ECDSA certs are not supported by older clients https://www.cloudflare.com/ssl

I think there should be an option (or config parameter) that gives you control of what the default images schema should be.

Change History (3)

#1 @boonebgorges
4 years ago

Thanks for the report, rupiee. It's likely that this is a duplicate of #32112. See [32384]. Are you running WP 4.2.2? If so, and if you're still having this issue, please describe in more detail the steps you are taking, and what you mean by "linked as HTTPS" - does this mean the src of the img tag, or the href of the a tag, or something else.

#2 @chriscct7
4 years ago

  • Keywords reporter-feedback added

#3 @johnbillion
4 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #32112.

Note: See TracTickets for help on using tickets.