WordPress.org

Make WordPress Core

Opened 5 years ago

Closed 13 months ago

#32777 closed defect (bug) (invalid)

Visual Post Editor is missing - Firefox dev console shows incorrect include link for tinymce

Reported by: getspatial Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2.2
Component: TinyMCE Keywords: reporter-feedback
Focuses: Cc:

Description

My client mentioned that the visual editor was showing white with no toolbars available. This is a new site, and had recently updated to WP 4.2.2. After searching various items on web, went in to look around. I deactivated and removed all plugins. Site is using Twenty Fifteen theme. Logged out, cleared cache, logged in again, still not working.

Downloaded wordpress 4.2.2 from wordpress.org to local computer. In webhost, deleted all wordpress files aside from wp-config.php and wp-content directory.

I uploaded new wordpress files from wp 4.2.2 download to web server. Visited site, verified that it is working correctly. Logged in. At this point, there are no plugins installed. Site has 1 post and 3 pages added.

Went to Add New post, Visual Editor still not showing.

Opened Firefox Web Develop web console and reloaded Add New post page.

Console window listed the following:

02:01:46.573 "Failed to load: http://experiencelanguage.org/wp-admin/http:/wp-includes/js/tinymce/plugins/media/plugin.min.js"1 tinymce.min.js:4:2622
This repeats for every ".js" file in the tinymce plugins directory. I am attaching a screenshot of the errors.

Looking at the url, it is obvious why it is failing, as the url is a concatenation of two different paths. I am not sure where this mashing together is occurring, or how to correct it.

Any assistance would be very much appreciated.

Thanks,
Russell Mercer

Attachments (1)

Console_-_httpexperiencelanguage.orgwp-adminp_2015-06-24_02-37-01.png (93.0 KB) - added by getspatial 5 years ago.
JS errors when loading Add New post page

Download all attachments as: .zip

Change History (3)

@getspatial
5 years ago

JS errors when loading Add New post page

#1 @iseulde
5 years ago

  • Keywords reporter-feedback added

Hi @getspatial,

Sorry for the late reply.
I'm not sure how there can be http:/ in the middle.
Could you paste window.tinyMCEPreInit.baseURL in the console and paste here what you get?

#2 @azaozz
13 months ago

  • Resolution set to invalid
  • Status changed from new to closed

No response in a long time. Assuming that http: in the middle of the URLs was another error that was fixed in the meantime.

Note: See TracTickets for help on using tickets.