Make WordPress Core

Opened 9 years ago

Closed 8 years ago

Last modified 6 years ago

#33251 closed defect (bug) (duplicate)

Customizer hidden features: Shift+Click to edit widgets

Reported by: afercia's profile afercia Owned by:
Milestone: Priority: normal
Severity: normal Version: 4.2
Component: Customize Keywords:
Focuses: ui, accessibility, javascript Cc:

Description

Looks like the Customizer has some little, hidden, gems I've never noticed before and probably many users haven't noticed too. For example, how many know that hovering on a widget in the preview iframe shows this title attribute? See below:

https://cldup.com/r9cTBdwm2b.png

And it works :) Shift+Click will open the widgets section in the left sidebar, with the related widget expanded and ready to be edited (maybe focus should be moved there):

https://cldup.com/wH-GHQmpbw.png

By the way, the point is this feature is really hidden. The only chance users have to be informed about this is when by accident they hover on a widget and notice the title attribute. Not to mention touch devices, as far as I know, won't ever show this. There are no instructions or Help text that mention this, as far as I know.

Considering also #24766 I'd recommend to don't rely on title attributes alone to convey such important information. It would be a nice, interesting, challenge trying to find a new design/UI pattern to be used instead of a title attribute. Call for designers :)

Also, from an accessibility point of view, this UI control is not focusable and hardly usable for keyboard users and screen reader users.

Change History (10)

#1 @westonruter
9 years ago

See also #32681 which is for adding shift-click for editing menu items.

#2 @celloexpressions
8 years ago

My suggestion is to start trying a bunch of different options in a feature plugin and trying to spur heavy adoption (relative to most feature plugins). If we can get a lot of user testing and feedback on theme compatibility, we should be able to find a solution that works visually for a majority of sites.

#3 @paulwilde
8 years ago

See also #27403, possible duplicate.

Last edited 8 years ago by paulwilde (previous) (diff)

#4 @westonruter
8 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Closing as duplicate of #27403, which I just updated to include some of the points here, including the suggestion to add long-press for editing elements in the Customizer.

@afercia this should have been addressed:

Also, from an accessibility point of view, this UI control is not focusable and hardly usable for keyboard users and screen reader users.

#5 @westonruter
8 years ago

@afercia oh, I think I misunderstood that last point. You're talking about the UI element in the preview, not the control in the pane. I've added your note to #27403.

#6 @afercia
8 years ago

@westonruter: thanks Weston, yep in the preview. I see everything is covered in #27403 and I seem to recognize that screenshot :D

This ticket was mentioned in Slack in #accessibility by afercia. View the logs.


6 years ago

#8 @afercia
6 years ago

  • Keywords close added

@westonruter @celloexpressions hi, thinking this ticket can be closed now that there are the clickable blue things?

#10 @afercia
6 years ago

  • Keywords close removed

Ahah sorry :)

Note: See TracTickets for help on using tickets.